No gamepad detected

I have installed my Picade using the youtube instructions and really look forward to be using it

But - it doesn’t work. It comes up saying “No gamepad detected”

What I have done :


after reboot :

root@retropie:~# dtoverlay -l
No overlays loaded

root@retropie:~# dtoverlay picade

  • Failed to apply overlay ‘0_picade’ (kernel)

I have also tried : watch -n 0.1 gpio readall

  • And it seems to detect all buttons and joystick directions

/boot/overlays/picade.dtbo exists
dtoverlay=picade is in /boot/config.txt
/etc/udev/rules.d/10-picade.rules exists

I have also tried installed the newest and an older release of Raspian (and curl…) but still not able to load the overlay. Hwo do I get it to work ?

Sorry, cant help you but I’m in the exact same situation having taken rhe same steps. I have done it twice as well With two separate SDs.

Having tried the online update method pultiple times, instead my problem is finally solved by the “Automatic installation” procedure mentioned below:

Hopefully this might solve you problems as well!?

Unfortunately it doesn’t work for me.

I have created a new retropie image and followed the autmatic installation. (It creates a picade overlay file and the lines are put in /boot/config.txt - but still fails to load…)

pi@retropie:~ sudo dtoverlay -l No overlays loaded pi@retropie:~ sudo dtoverlay picade

  • Failed to apply overlay ‘0_picade’ (kernel)

To fix the problem, update your gamepad drivers and check if that helps. Gamepad not in Device Manager – If the gamepad isn’t in Device Manager, it’s probably not recognized by your system. To fix the issue, you need to find any Unknown devices in Device Manager and update their drivers.