New Picade - Software configuration issues


#1

Hi all,

Built the new Picade, burned the RetroPie to SD, added the hdmi_force_hotplug line to configure.txt and booted. RPi Model 3B+

Now, according to the Picade page, I should:

Connect a USB keyboard to your Pi, and connect to Wi-Fi in the RetroPie menu.

However, I only get to the RetroPie “no gamepads detected” screen, so, not able to go to a menu at all? Can only manually set up keys in this screen.

However, dropped to terminal, run raspi-config, got WiFi.

So:

Press F4 to exit to the terminal and then type curl https://get.pimoroni.com/picadehat | bash to run the Picade HAT installer.
Reboot your Pi, if it doesn’t prompt you to.

Rebooted, done.

Press the “Alt” key on your keyboard and then select “Configure input” to configure your Picade’s controls. You’ll find that the sound and power button should both be working now too!

Can press alt what I want on my attached USB, but nothing responds.

Only thing I can to is either setup my keys in RetroPie, or drop to terminal…

What am I missing here? Already manually configured some keys (is there an overview of how they should map?), then I get into RetroPie. But I think this is not how it is supposed to be, and am wondering if something is wrong. My powerbutton works, but the led isn’t for example. Is this a driver issue?

Also: watch -n 0.q gpio readall doesn’t work since “gpio” isn’t installed. Manually apt-get install raspi-gpio gives that it already is installed…


New Picade joystick doesnt work!
#2

The “gpio” binary is part of the WiringPi package. You should sudo apt install wiringpi

When you’re at the configuration screen, does holding any button on the Picade controls work to start input configuration?

Note: it will always say “No gamepads detected” since Picade pretends to be a keyboard.


#3

Thx, will install gpio separately.

Yes, can manually configure inputs, but am left wondering what the left&right shoulder/d-pad config etc should be. Somehow assume(d) that the picadehat script would set these up. Or is there a config file I can manually copy?


#4

Ah! Nope it doesn’t set them up automatically. I suppose it could do. The trouble is, how you configure them depends on what you play and I don’t think there’s a right answer.

I usually use the left/right buttons for L1/L2 R2/R2 which map onto some things like the GBA and SNES controls, and I leave all the analog stuff unconfigured.

I didn’t configure a hotkey button, either, and let it default to Select which, in retrospect, might have been a mistake.

Edit, just reconfigured mine to:

[LT] /--------------------------------\ [RT]
           [U]           [B] [Y] [RS]
        [L][D][R]      [A] [X] [LS]
     \--------------------------------/
        [START]             [SELECT]

with LT (Left Trigger) as the hotkey enable since I had trouble with it on SELECT since it kept entering recording mode.

This makes [LT] + [START] exit, and [LT] + [X] go into the emulator config menu, which are both super handy.


New picade volume control