Picade set up not working. Please help before I tear my hair out!

Hi all. New member so please be patient with me. I received a Picade for Xmas and have been trying to get it set up but I’ve hit a wall.

I believe it’s all connected correctly.

I believe it’s connected to WiFi.

I’m at a stage where, when I switch on the Picade, Retropie automatically starts up. I get the message Welcome No gamepads detected. Hold a button on your device to configure it. Press F4 to quit at any time.

If I press any button on the Picade nothing happens.

If I plug in a USB keyboard I can start to configure but I don’t want to run it via a keyboard. If I press F4 I end up in a Retropie command menu.
Is this where I’m supposed to type curlhttps://get.pimoroni.com/picadehat|bash ? If I do that I get the message ‘No such file or directory’.

I don’t know where to go from here. I thought I already had the Picade hat installer sorted, which is the thing asking me to configure buttons?

I’ve noticed the Picadehat has a Switch and an LED on it. Do these do anything in this context? The LED is off and the switch doesn’t seem to have any effect.

Any help with this would be greatly appreciated.


Are you feeding power via the Picade X hat Micro USB? Thats likely a must for the power button on the hat to work. I see this on the Picade X Hat product page


With micro-USB power connected through Picade X HAT you’ll need either to tap the connected power button or the button marked “switch” on the HAT to power on your Pi.

I don’t own a Picade and have never set one up, but I usually run the one line installers from a terminal window in Raspbian.
curl https://get.pimoroni.com/picadehat | bash
Is what is shown for the Picade X hat, your clip and past is missing some spaces is why I posted it again.

Thanks for the reply.
I was missing a space so the Pi reacted when I retyped and installed the picadehat installer. However I think this is where I was anyway! The installer seems to be the thing asking about configuring buttons (control pad) which makes sense.

I still get no response at all from the joystick or any of the arcade buttons.

The Picadehat still doesn’t have an LED lit up but the only power supply to the whole set up plugs into the hat, powering the screen and the pi also. So I’m sure it’s getting power.
I’ve checked the leads going from the buttons into the hat and they all seem fine.
The power button for the whole Picade unit is wired to the hat and is working fine.

So basically, everything seems to be working other than the joystick and buttons.

Sounds like you might be missing or have a bad ground connection somewhere. The joystick and buttons likely share a common ground. As I mentioned though I don’t have a Picade so I’m not sure how much more help I can offer.

Okay thanks for your help.
I’m wondering if the hat may just be faulty or something.

Double check all the plugs on the X Hat. It looks like it would be easy to plug one or more in the wrong way. After that, if you want, go to the Shop page. Then look for a contact us link at the bottom. Then put a link to this thread in the e-mail. That should get to a fast response, just remember its the weekend. You may not here back until business hours on Monday. ;)

Thanks, I’ve contacted support via the shop page as you’ve suggested (and have linked to this thread) so we’ll see what happens.
Thanks again for your help - really appreciated.