Picade HAT not working


Received my new Picade hat today and followed the setup instructions on a retropie image that was already being used. Wired up the controls and when I push the soft power button, the system boots to retropie. I go to the controls setup and the buttons and joystick are not seen and cannot be configured. The soft power button also will not shut down the system and this has to be done the usual way with a keyboard command.

Also purchased a Picade pcb (not hat) and connected this and this works straight away with the same retropie image.

Any suggestions would be very welcome as this is going into a bartop arcade machine made from lego that I hope to show off at an event on Wednesday.


Which setup instructions did you follow?

Do you have a mouse/keyboard attached to your Pi that you can run some debugging steps with?


Followed the ones on your site at https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-picade-hat
Yes, I have a USB keyboard & mouse.


Can you hit F4 to drop to the command line and see what you get if you run:

cat /var/log/picadehatd.log

You should see something like; “Picade HAT daemon running…”

Next try running the showkey command to see if it shows anything when you press a key.


cat /var/log/picadehatd.log
no such file or directory

press any key (I tried presses button and joystick)
no output
keycode 28 release for 10 seconds that exits


I received my Picade hat this week as well and I do experience exactly the same issue…
I’m following your track and getting the same messages…
See how I set it up, if it can help:


Curious, sounds like the software isn’t running at all.

Could you try running: sudo picadehatd


It says “command not found”


Says command not found


Then you have no working software at all… can you run the setup.sh found in the repo and post the full output here?



git clone https://github.com/pimoroni/picade-hat
cd picade-hat


actually, there should already be a clone of the repo in ~/Pimoroni/… if not that’s the problem right there!


I think the most likely is that the install went fine but the file is not executable, try (+reboot):

sudo chmod +x /usr/bin/picadehatd


Great! It works for me now! Can map the buttons and stick now!
Hope this is solve for kryten as well.


it should, hopefully. It seems that editing files live in the repo using github directly messes file modes. The setup.sh now takes some steps to avoid running into that pitfall again, sorry about the false start. Enjoy!


Thanks! Enjoying it now!


Thanks everyone. That’s working fine now. I really appreciate your help and am looking forward to completing the project now.

I am going to finish wiring up all controls and then when I get to work tomorrow morning, fit them inside the lego case. When it’s complete, I will try to post some pics of what you helped to create.



Hi, I’m having the same issue but these steps haven’t worked - bought a Picade last week and just came to install the Hat drivers… It appears to download and install but when I look for the log it says no such directory. Joystick, buttons, speaker, 3 second shutdown etc not in action… I’ve tried reinstalling, removing the Hat then reseating it but can’t think of any other solutions… If it makes a difference mine is the 2018 model, thanks :) still liking the product and had fun building it!


In all cases Picade HAT and Picade HAT X now require the latest version of Retro Pie IE: based on Raspbian Stretch.

The easiest way to do this to back up your ROMs/configuration and re-image from the latest RetroPie download. You can update the OS in theory, but it’s non-trivial, see this for example: https://retropie.org.uk/forum/topic/16145/retropie-upgrading-raspbian-jessie-to-stretch


Ok so i am in the same boat. Built 10 of these last year with the old picade hub and they worked out great. Ordered another 10 this year…built it and get squat. I am trying to use an existing image with 4.2 i think. Yes I did the download as per the instruction (github). But when i restart it still does not detect the hat.(also gives me so errors) so reading (before this thread) i thought if I simply update the pie to 4.4 that might help. However when i do the script update and then basic install it breaks my image doesn’t boot into emulation station actually the keyboard goes dead.

So…since there are some great hints here what should be be my procedure from the list…other than start fresh which i rather not do. Thanks in advance for your help it is a great tool and the kids love building it.