Help! new picade no buttons work


#1

I just finished building the new picade and when retropie/emulation station boots up I get “no gamepads detected”. I have tried pressing and holding down a button …many different ones… but none work.

The buttons are all wired up fine, why are none of them working? please help!


#2

Did you run the Curl command to download the picade scripts?

I recently managed to get the same problem fixed, just need to know where you are at with it.

You should have run

curl https://get.pimoroni.com/picadehat | bash

from the command line to get the software and then reboot.


#3

Nope, I didn’t. (the last model picade I had I just installed retropie and it worked right away)
I’ve no idea how to do commands like that, I’m a gamer not a programmer but I will look into it.

Thank you

tbh I’ve no idea where to even type commands in and I’ve not been able to setup the wifi as it’s not registering any buttons. you’d think the instructions or videos would cover something like this… but no.


#4

You want to plug a keyboard into your USB port on your Pi. Then, when it asks to setup the controller, hit F4.
From there you get a command line and can run ‘raspi-config’. I forget, but you may need to put the ‘sudo’ command in front of it. So it may look like:

sudo raspi-config

from the command line. You’re doing this so you can setup your wifi, unless you plug it directly into your ethernet.

Once you have wifi, you can run the previously mentioned command. WARNING: If you’re in the US, you may also need to change the keyboard settings in raspi-config. The UK keyboard layouts don’t map the ‘|’ key properly for US keyboards. Here’s my steps for getting it setup:

  • Image Retropie to SD
  • Boot with SD
  • F4 on keyboard to command line
  • raspi-config
  • Setup WifI
  • Change Keyboard Layout (It looks complicated, but you just want to choose US settings in the menus that come up)
  • curl https://get.pimoroni.com/picadehat | bash
  • reboot (from the command line, note the ‘sudo reboot’ and the ‘sudo shutdown now’ commands, pretty obvious what they do)

You can then see where you are from there.


#5

There is a Pimoroni video called ‘Getting up and running’ that details how to connect a USB keyboard to get the WiFi etc working.

https://learn.pimoroni.com/tutorial/sandyj/assembling-your-picade

It’s near the bottom of this page.

Hope that helps,

Simon.


#6

That’s pretty much the exact steps.

(You will need sudo raspi-config btw.)


#7

Thanks a lot! I’ll try that.


#8

Indeed- as above. Us switching from a USB-based Picade to Picade HAT X (and Picade HAT) makes the hardware a lot more compact, cheaper and simpler, but on the flip side it means you need drivers installed to make the HAT behave like a keyboard! Swings and roundabouts.


#9

Thanks everyone, I installed the files, did some fiddling about with the wiring and now we’re good!