New Picade Joystick and Buttons do not work


#1

This is my second Picade. I was able to get the first edition working with little problems. However, I’m having a few big problems with the new one.

First, none of the buttons or joystick works. After connecting everything I typed in the command curl -sS https://get.pimoroni.com/picadehat | bash But I couldn’t type the | symbol. Does that make a difference?

I reconnected all the buttons, joystick, but still nothing works. I have the right power supply and a working version of retropie. I double checked all the connections!

My power button will turn on my picade but it doesn’t turn it off.

No sound

I’ve been following this thread PICADE - X Hat- Buttons + Joystick not detecting

but it hasn’t helped me fix any of my problems.


#2

The fact that you can’t type the | symbol will absolutely cause problems! It means that the software install won’t work and everything that you describe - no controls, no power down, no sound.

You’ll need to find a way to type the one line install with the | symbol.

Do you know how to use SSH?


#3

I have the same no | pipe symbol problem on my keyboard with the default UK layout in Raspbian. Once I switch to English US its where it should be. Doing a copy past while SSH’d in will work as far as I know.
I don’t know how you change keyboard layout in Picade?


#4

#5

Once I used raspi-config and changed the keyboard to a generic US keyboard it worked!!!
Thanks!!!


#6

Glad to hear it was that easy.