Picade - Piecade Hat - Cant Install - No Forward Slash


#1

So bought the picade from pimoroni came with everything. I bought a new SD card and put on retropie.

So everything loads up as it should, but then I get the message no gamepad detected. So I work out I need to install picade hat software.

Heres where the problem is there is no / forward slash available instead it just puts up a square block, so I cant get to website to download the software for the hat.

Ive double checked all the details and the keyboard is set to UK and it the lang and all other settings. Ive also tried every key combination to get the / but to no avail. Its an cheap advent keyboard.

Anyone come across this before? I saw on one forum that it could be that keyboard is underpowered and need more power? Im using the adaptor that came in the box.

FYI I’m a novice at this and i’m learning along the way


#2

If its an English US keyboard you need to set that as your layout. I run into a similar issue. With the default UK keyboard layout I have no pipe key | . I hit every key on my keyboard but could not find it. Once I switch it to English US I have it where it should be.


#3

You can change keyboard setting using the raspi-config command. You have to do this as root so type sudo raspi-config.

Under option 4 you can change the localisation settings. Is you choose I3 it automagicaly change the keyboard layout.

When this does not work you can always try to connect over SSH. Find the Ipaddress of you PI, this is shown when you login on the prompt under IPaddress.
You need software for this that you can run from a windows box, I personally prefer Putty.
Connect to using putty and username pi and password raspberry (or if you changed it, the password you choose)

The keyboard layout will be probably different there.

I hope this will help.

Succes!