Issues with keyboard when picade software installed

I’ve had my Picade (10" PICO-8 edition) for a while now, and a few days ago I installed the plasma buttons on it.
In doing this I had to use the console, and for some reason trying to type acts like I pressed Ctrl+the key I was typing, no matter they keyboard I used or how many times I restarted.
Pressing the D key (so I got ^D) meant it exited back to the GUI, and then hitting F4 again to return back to the console fixed it. It was rather annoying, but since it didn’t cause much trouble I just ignored it.

The day after I stuck an ordinary Rasp. Pi OS Lite card into it, as the Picade has a nice screen to use with the framebuffer console :)

Everything was working fine, until I decided to try installing the picade software so that the power button would work to turn it off. The software said that it had detected I wasn’t running RetroPi, and that it had only set up the stuff that could work without it.
However, after a reboot, I was having the same keyboard issues with everything being Ctrl+TheKey, and this time I couldn’t fix it by returning to the GUI, as I has none installed.

How do I fix this issue? If not fixable, how do I uninstall the software?
Note that I have to fix it remotely via ssh, as without working keyboard input I can’t do anything directly on the pi.

Thanks in advance! :)

I saw this on the github page.

  • Clone this GitHub repository somewhere onto your Pi: git clone
  • Enter the new directory: cd picade-hat
  • Run the installer: sudo ./
  • Reboot sudo reboot

If you already have that folder / directory, you can run the following command from that folder to uninstall the picade sofwate.
sudo ./

1 Like

The uninstall script worked, thanks!
I hadn’t realised one existed as the build instructions inform you to use

It’s a bit annoying that I can’t have the power button work, but guess that’s that.

The Picade X hat uses the same two GPIO pins for power and shutdown that the On Off shim uses. The on off shim software will likely work and do what you want. IMHO its worth a try.

Picade X HAT at Raspberry Pi GPIO Pinout

OnOff SHIM at Raspberry Pi GPIO Pinout

OnOff SHIM (micro-USB) – Pimoroni

curl | bash

1 Like

Another option is to add an entry to the config.txt.
Pressing the XHat power button should then have the Pi do a proper shutdown. This won’t remove the power to the Pi though, like the original daemon does. Probably won’t start up with the power button either.