For those in the states


#1

Hi Folks, I just finished building one of the new Picades and thought I’d share a few findings for those putting one together on the West side of the Atlantic…

After you complete the build and turn it on for the first time, you need to get the software for the Hat…this is where I encountered the first ‘issue’. The RPi defaults to a UK keyboard layout and the ‘|’ character on in the command:

curl https://get.pimoroni.com/picadehat | bash

…is not immediately available (as far as I can tell) on a US keyboard. (I’m using the latest Retropie 4.4 based on stretch on a Pi 3B+)

Never fear…it’s easy to change with the following;

sudo nano /etc/default/keyboard

change XKBLAYOUT=“gb” to “us”

save the configuration and exit, then reboot.

I also noticed that if you update the retropie software, for some reason it defaults to a password login upon reboot…you can change this in raspi-config, boot options…

HTH someone! The new picade is very cute…;)

Cheers,

Nick


#2

Here in Canada I ran into the same no | key issue with my English US keyboard. I ran sudo raspi-config and tried to fix it that way but failed miserably. I tried 4 or 5 of the US keyboard layouts and still didn’t have the | symbol. That made running the one line installer impossible. I gave up running Raspbian Lite as a result and switched to the full Raspbian. Changing my keyboard layout from the configuration GUI then worked. Will give your file edit a try next install though, thanks for the tip. =)


New Picade Joystick and Buttons do not work
#3

The | key is accessible through right Alt and - or something up over that side of the keyboard- I can never remember! This keyboard frustrates the heck out of me- I don’t know what its origins are but every other UK keyboard I’ve used has | on the same key as \ right under A and left of Z accessible with Shift. It’s hard to tell people to type | when it’s not even visible on the keyboard! Some people result to copying and pasting it, or using SSH from a host computer.


#4

On my keyboard, Logitech K360, the | \ key is on the extreme right, just above the Enter key. I can remember trying every key with shift, ctrl too I think, not sure if I tried alt though. Will try to remember next time I get stuck though.


#5

an issue that has annoyed me many a time— |||||


#6

Thank you for leaving plenty of | around for people who need them.

Please, if you copy and paste one of these | make sure you leave some more for future users experiencing this problem.

I’m afraid mine have holes in so they’re not much use: ¦¦¦¦