HQ camera problem

Hi -

I have a raspberry pi 4, an HQ camera and the 6mm lens. I’ve set the pi, camera and lens up as recommended (so no C-CS adaptor, I’ve screwed the back focus all the way in), I enabled in software and I’m using “motion” to get a preview image from the camera. I get an “image” but it is basically one big blur : totally out of focus. Fiddling around with aperture and focus rings I cannot get it to improve focus at all.

I never like to accuse the product of being faulty but I’m getting to the point where either I’ve missed something basic or there is a fault.

Checking the sensor I cannot see a supplied covering so I don’t think that’s it. Doesn’t ‘feel’ like a software fault - if I wave my hands around in front of the lens or move the camera its clearly picking up light and an image of sorts.

Is there anything else I can try? Could the camera be faulty?

  • Daniel

I’m no expert ,so i started here , try taking a picture using the command prompt ,and you should be able to setup focus easier ,works for me .https://projects.raspberrypi.org/en/projects/getting-started-with-picamera/3

Thanks for replying, using the ‘raspistill -o’ command I can take a picture, I get exactly the same result as using motion. I’ve attached an example.

I have the HQ and the 16mm telephoto lens. I just screwed it on and adjusted it.
If you run this python code you can get a 30 second preview. You adjust the focus and see if its better or worse on the fly with a live video of what the camera sees.
I’m sure there are other ways to get a preview, its what I had on hand. I had other code in the file for the pan tilt hat and just striped it out before posting it.

from picamera import PiCamera
from time import sleep
camera = PiCamera()
camera.rotation = 180
camera.resolution = (1280, 720)


Ah, it appears its raspistill -t 0
And ctrl-c to exit back out.

Thanks for responding as well - I’ll admit it I’m being a cheapskate and doing all this remotely using motion so I don’t need to get a micro hdmi adaptor :). I’ll get one and plug it into a monitor, use proper preview mode as you suggest and make sure that its not something else. The image I posted was with everything screwed in and a reasonable amount of aperture and I’ve spent a lot of time going back and forth in small steps trying to find a focus region, but perhaps the focus region is more sensitive that I expected.

  • Daniel

My HQ Camera setup is running Motion Eye OS, headless with no monitor etc. I can relate to what your going through. Every once in a while I’ll adjust the wrong ring and lose focus. It’s a very narrow spot where its crystal clear. It’s a royal pain to adjust, walk to the other room to view the image etc, wash rinse and repeat. I have a SmartiPi setup that is nice and portable. I set that up right next to the camera, open the feed and focus it. I should use those locking screws but I took them out. I do occasionally move this camera to different locations and refocus it. Not very often, but often enough that locking it wouldn’t be that big of an advantage.

So I tried carefully adjusting focus but no luck. I then removed the focus ring and held the lens in front of the sensor, and got a decent image (well it was in focus anyway). It appears to need the lens to be 1 or 2 mm closer to the sensor than you can achieve with the focus ring alone, so I guess either it’s the lens, the sensor position or the thickness of the focus ring thats the problem. Thanks for your help!

I was preparing an email to support and noticed that on the product pages the focus ring for the camera looks different the one I received. The one I have has an extra ~5mm ring. Before anyone suggests that I’ve left the C-CS mount adaptor screwed in, I’m sure that this isn’t the case, its all one piece of plastic and I have the adaptor sitting on my desk next to the camera.

Looking in the docs and on other web sites, most pictures don’t look link this - the lens buts right up to the thin focus ring however in some places I can see photos that show the extra ring.

I’ve attached a photo showing what I mean, and marked in red what I’m talking about.

(I’ve unscrewed the focus ring quite a long way to show it more clearly.)

All I can tell you is I have the other lens, the 16mm telephoto
Lens for the Raspberry Pi High Quality Camera – Pimoroni
My setup has that ring in place, it’s part of the camera right? I left it on.
Will your lens screw on without it?

So does your ring have the part marked in red on my picture? If you compare to the product image here for example they differ:

To answer your question, the focus ring will come off (it screws in to the “body” of the camera once you have loosened the screw), it came with the camera. The body side where it unscrews is a different size to the C/CS mount so no, the lens won’t screw on without it - the lens needs to screw into the focus ring on mine at least, but perhaps they have changed the design.

OK - I feel kind of supid, kind of annoyed that this isn’t more clearly documented. After a lot of brute force, I managed to unscrew the extra part from the focus ring. I’m now left with what looks like two C-CS adaptors :)

Anyway thanks for your help!

Yeah I guess its two rings. The thin bigger diameter part right up next to the camera, which I think is the focus ring. And the narrower wider bit that the lens screws into, which I think is the CS to S part? Mine has both in place.