Hyper Pixel 4 and Raspberry Pi model 4 (4 GB)

How do I get the Hyper Pixel 4 and Raspberry Pi model 4 (4 GB) to work together. It worked once until i rebooted and now there is nothing! have reinstalled everything again and still nothing.

Raspberry Pi 4
4 GB
Raspberry Pi OS
A port of Debian bullseye with pi desktop
(PI 3/4/400)

Again, It worked once until I rebooted and then the screen was black and no back lights. Redone everything I had done for it to work the first time and still no change. BLACK SCREEN.

It did the same on pi 400. Worked until reboot than blank screen.
As I mentioned before I can see the DPI display is showing in screen config as if it’s all working. I can us both in the screen configuration screen. So I do believe the software is working but the hardware (hyper pixel) is not.

I also seen several comments in the pimoroni forums many people are dealing with dead hyper pixel displays!!

What changes have you made to /boot/config.txt?

I’ve been round the houses with this screen recently, in the end I managed to decipher this post:

The post says you only need this one line in your config.txt, but it really means is you need to keep /boot/config.txt completely untouched, apart from adding this to the very bottom:


Hope that helps.

Edit: Leave the existing dtoverlay line in place too, don’t remove it or comment it out.

Ok everything is back to redone! ran the pi 4 installer and added the dtoverlay at the end of config.txt

This is my current config.txt

For more options and information see

Raspberry Pi Documentation - Configuration

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display’s size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Uncomment some or all of these to enable the optional hardware interfaces


Uncomment this to enable infrared communication.


Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)


Automatically load overlays for detected cameras


Automatically load overlays for detected DSI displays


Enable DRM VC4 V3D driver


Run in 64-bit mode


Disable compensation for displays with overscan



Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.




Run as fast as firmware / board allows



dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6


Hmm, nope, you’ve added a lot more than just the single line I suggested. To repeat - keep the config.txt file completely vanilla and just add this single line at the bottom:


I did only add the one line. The install added everything else

If you read the linked announcement - “users running the latest and greatest Raspberry Pi OS should forego our installer…”

The extra lines are coming from the installer, that you no longer require. I imagine they are tripping things up.

So do a clean os install and just add that line? Don’t do anything from get hub?

That’s what the PSA linked above says. Also contains info about rotations, and I would highly recommend you read it and then proceed.

ok did a clean fresh OS install and added only
to the end of the config.txt and still no display !
i still think its a bad display because the dpi shows up in the screen config and it shows overlayed on my desktop!