Hyperpixel 4 with touch - headache with touch!


Got HyperPixel 4 with touch on my pi4. Was surprised to see the vertical default layout, easily remedied by setting the /boot/config.txt with added :rotate and setting a “left” flag.

However on reboot - the touch screen isn’t aligned, like left is up and up is left etc etc and any single touch reports a coordinate opposite based on perceived position because of the mixed up orientation.

The command line for hyperpixel4-rotate fails with an exception to open the display, even when run as su so that’s no option.

How can I get this to be like for like, make the screen work as it should ?

If you run hyperpixel-rotate on the pi itself (via VNC or using mouse/keyboard) rather than SSH, it was working for me. @gadgetoid was twiddling his moustache tips in frustration earlier in the week trying to get this working with me.

I presume you’ve seen the instructions to use the pi4 branch on GitHub?

HI there - not much luck doing it that way either I’m afraid; i.e. - Yes the command runs properly on the Pi itself via VNC, but the results are the same …

The visual rotation is fine, the touch is gaga - technical term.

Was your exchange with Captain Gadgetoid on Twitter par chance ?

No, discord! Search for pimoroni discord and we’re in there.

Having difficulty finding the relevant area of conversation there …

Lots of Hyperpixel chat, but can’t find the bit specific to you and your issue being resolved

Turns out that this issue and resolution on Github addresses this directly, but a bit inelegantly at the moment. Looks as though Gadgetoid is investigating further.


Also having trouble with hyper4 & rpi4. Sometimes the pi just stops booting, most of the times touch isn’t working. Going to try with raspbian stretch :|

EDIT : Tried again, the screen works, the touchscreen is not calibrated :|

Hi all,

im currently very new to all aspects of this but ive been over all reported fixed for the pi4 / hyperpixel 4.0 issues ive been seeing.


This currently is the only way im able to get the display working.

The touch controls are inverted in both X and Y.

Rotation left, right or inverted always results in the same touch control issues = X and Y mixed up (down = right, up = left)

I’m using “DISPLAY=:0.0 hyperpixel4-rotate right” for rotation movements.

I work through all steps listed.

On running the “make” command im greated with the follwing message, im unsure of this is an error?

dtc -I dts -O dtb -o hyperpixel4.dtbo hyperpixel4.dts

hyperpixel4.dtbo: Warning (unit_address_vs_reg): /fragment@2/overlay/i2c@0: node has a unit name, but no reg property

hyperpixel4.dtbo: Warning (gpios_property): /fixups:gpio: property size (21) is invalid, expected multiple of 4

After this I get nothing on the reboot of the pi, hyperpixel, HDMI, SSH VNC connections all fail.

I also tried (grabbed from twitter) input set-prop “pointer:Goodix Capacitive TouchScreen” “Coordinate Transformation Matrix” -1 0 1 0 -1 1 0 0 1 with someone reporting the same issues, this resulted in the curser always going to far top right no matter where the finger placement.


Display working but the alignment of off, centre finger placement results in curser being located to the left and low.

I’ve currently run the setups above on NOOBs Raspbian and an image version of Raspbian.