HyperPixel Touchscreen malfunctions


My new HyperPixel 4 looked very surprising until I tried to use the touch screen function, its totally useless because of a terrible calibration (I suppose). I tried suggestion on different forums and web sites but nothing helped. I shouldn’t need to dig very deep into the calibration world to fix it, have no experience of this system but from others Windows etc. The screen is installed on a Raspbarry 4 and with Raspbian, ID 10 named Buster.

Any suggestions?


Hello,I don’t own one ,yet ,did you check The pimoroni github for issues ,if not might be some help there good luck https://github.com/pimoroni/hyperpixel4/issues?q=is%3Aissue+label%3Anotice+

Do you have anything else plugged into the Pi’s GPIO pins?

And have you removed the protective film from the screen?

Nothing else is plugged into the Pi’s GPIO pins. The pointer moves in the opposite direction as the screen. Didn’t notice this before. Weird, but maybe some logic behind the fault that my limited knowledge can’t grasp. Moving finger left and right moves pointer up and down, moving finger op and down moves pointer left and right. Problem stays when changing screen orientation. The problem must be in the configuration of the touch screen function, not in the screen. Can not find any configuration file of the touch part, not in screen def. or any external def.

Did you rotate the screen with a config.txt edit etc. I’m pretty sure you didn’t but I better ask anyway.

It kind of sucks, but if it was me, I’d start over with a new install of Raspbian, fully updated. And rerun the Hyperpixel installer. Just to be sure it wasn’t a glitch during setup.

Thanks for your comments. I rotated the screen command line. Will reinstall Raspbian tomorrow, its late here in Sweden now.

If you use the wrong rotate command it will only rotate the image.
On my Pi foundation screen if I use display_rotate the image rotates but the touch stays where it was.
If I use lcd_rotate they both rotate and the touch matches the image and is usable.

Hi alphanumeric,

Before bedtime yesterday I reinstalled HyperPixel one more time. Then suddenly everything worked fine. The system was corrupt before, not the computers, but mine. I used the wrong commands, the type fault you just described. Thank again for your assistance.

Sorry about this.

Nice to hear you figured it out. Stuff like this happens, even to those of us that “think” we know what we are doing. ;)

@jand Can you help here with screen rotation?