I2C LCD backpack and Rpi A

I’m having trouble getting my 16x2 LCD to display anything when used with the Adafruit I2C LCD backpack on a Rpi Model A. I also have an Arduino Uno to compare with and I’ve successfully verified that both the backpack and LCD work.

On the Rpi I am using pin2 5v for VCC, pin 6 for GND, pin3 SDA for DAT and pin5 SCL for CLK. I’ve checked if the I2C device is active and it is at address 20, and also specified this in the library. I have tried 2 libraries (https://gist.github.com/DenisFromHR/cc863375a6e19dce359d) which run without errors but just nothing is displayed on screen. I have the LCD contrast turned right up too but still nothing. I’ve also moved VCC to pin 1 (3.3v) but the result was the same. Has anyone successfully used the LCD and backpack together on a RPi ? if so please help.

I have that display and one of those backpacks, I’ve only ever used it on my UNO though.
I toyed with the idea of using it with one of my Pi’s but never followed though on that plan.
It may be because the UNO uses 5V logic and a Pi uses 3.3v logic signals? Best guess anyway. A 3.3v high may not be enough to register as a logic 1?

Hi, thank you for reply. Does this matter if I am only using the 5v gpio pin to supply the backpack and not the 3.3v pin? Also I’ve now read so many guides where this backpack has been used with a Rpi for various projects and none have mentioned this so far. My thoughts were that the problem may be that this device needs to be activated, but again I’ve enabled i2c in the config settings too and installed the necessary tools (smbus and i2c) as well as the usual update and upgrades for the os.

I don’t know if it matters if you use 5V or 3.3V? It’s designed to run off of 5V, but if it sends 5V logic
signals over the i2c lines back to the Pi, it will damage the Pi. If I ever try this myself I think I’ll be putting a level shifter between the Pi and the display.
That being said, I saw this in the link you posted above, # requires RPi_I2C_driver.py
It’s not going to work without that driver. If you run that python file from the link in an IDE like Idle you should get an error message if the driver can’t be imported etc.

Sorry I forgot to say that yes I install the driver as I was not getting any errors when I ran the script. Everything was working fine apart from actually displaying the chars on screen. However I am pleased to report, that I now have a solution and its working great. I ended up installing Adafruit’ss Blinka library which is typically used in their CircuitPython set up. The installation guide here (https://learn.adafruit.com/circuitpython-on-raspberrypi-linux/installing-circuitpython-on-raspberry-pi) takes you through the initial set up to install all the dependencies. Then follow the guide here (https://learn.adafruit.com/i2c-spi-lcd-backpack/python-circuitpython) specifically for the Rpi using Python and I2C. Open a terminal and use Python3 to run the test script, and boom bang a bang, I had an text output on the display with backlight.
Although this method is a long winded set up, its still preferable to using most of the GPIO pins, as I need them for something else anyway. I hope this helps someone else out.

Ah, thats good to hear that you got it working.