I2c with ioexpander connected to hyperpixel

I have the Hyperpixel4 rectangle connected to a Pi4 and then I have wired up the IOexpander which I’m hoping to use alongside the screen.

As advised I have used the symlink.

sudo ln -s /dev/i2c-3 /dev/i2c-1

When I run the ioexpander example code I get the error “No such file or directory: ‘/dev/i2c-1’”

If I run lsmod neither i2c-1 or i2c-3 exist.

Any advice on this and getting the ioexpander to work with the hyperpixel4 is greatly apreciated.

Does anyone have any advice or experience with this? I would be really grateful.

I’m using these instructions:

It seems the IOExtender is the perfect fit for the hyperpixel-4 so was really hoping this would work without any problems.


Yay! Managed to figure this one out which isn’t bad for a newbie.

In case someone else has this problem I scanned for the I2C devices before and after adding the HyperPixel using ls /dev/i2*.

The i2c was actually /dev/i2c-22

I was then able to amend this according to the instructions:
sudo ln -s /dev/i2c-3 /dev/i2c-1

Replacing i2c-3 with the actual device number.