Using the I2C port on Hyperpixel 4 display


I am trying to use the Pimoroni IO Expander with the Hyperpixel 4 Sq on a Raspberry Pi 3A+. I have ran this script: sudo ln -s /dev/i2c-3 /dev/i2c-1. However I get this error: No such file or directory: '/dev/i2c-1'. I think its because the symlink isn’t working correctly and I don’t know how to rectify it. Any help would be appreciated!


Have you enabled i2c using sudo raspi-config first? The error No such file or directory: '/dev/i2c-1' suggests that the Pi can’t find the I2C bus.

Try running ls /dev | grep i2c to list the contents of the dev directory and search it for things with “i2c” in the name to see which busses are available.

I had enabled I2C in the config. I ran the ls command and the only item in the directory is i2c-11. Is this correct?

I’ve had this in the past, as far as I know it’s absolutely fine and is something to do with how Pimoroni’s software creates the “virtual” i2c port on the Hyperpixel board. All you need to do is substitute /dev/i2c-3 with /dev/i2c-11 in the command in the tutorial and it should work fine.

Worked perfectly! Thanks for all the help, you have saved hours of stress haha :)

You’re welcome, I’m glad I saved you some time!