Hyperpixel4 No Image

I recently bought a Hyperpixel 4 display for a Raspberry Pi.
I plugged it in, loaded the drivers but I get no image.
The unit has never shown any usable image.

If a Python script is running that outputs to the main HDMI screen, the Hyperpixel shows a dim, smeary and unreadable image.
The screen layout utility shows the HDMI and a new DSI-1 entry.
The DSI1 entry has FIXEDMODE for Resolution and 60.06 Hz fixed for frequency. I cannot change either.
If I do a i2cdetect -y 7 I get - - in all positions except for address 5D where it says UU

Can you help me sort it out please?

John A Jebb

The Hyperpixel doesn’t use i2c?
Do you have an i2c device connected? UU means under system control.
Actually, do you have any other devices connected to the Pi’s GPIO header?

Yes I have two i/o devices.
A 16 way digital i/o module at address 20 and an analog input module at address 68 and 69.
They both work.

I tried removing these modules and it made no difference to the Hyperpixel4.

John A Jebb

The Hyperpixel uses all of the GPIO pins and re purposes most if not all of them, including i2c.

If you want to use the Hyperpixel and i2c you have to use the i2c connector on the back of the hyperpixel. And alter your code to point to that i2c bus.

EDIT: As a test i would disable i2c in Raspberry Pi configuration, and remove those i2c devices. And then maybe run the hyperpixel installer again.

OK Thanks
I will disable i2c in the pi config and remove those devices.
I will run the hyperpixel installer again and see if the hyperpixel works.

Meanwhile please can you tell me how to use the i2c connector, where to connect it and how to alter the code.


John A Jebb

On the back of the hyperpixel4 there should be a black female header with a white i2c silk screened next to it. The layout is also marked on the board
GPIO 4 (int)
It looks to be reversed in order on the 4 inch square Hyperpixel. Not a big deal if you match the correct pin to the corresponding pin on your device.
I would think male to male jumpers should do it, assuming your i2c device has a feamle header on it.

Instructions for using the alternate i2c are here.

My Hyperpixel4 now works and gives a clear image.
The touch mouse works too.
Thank you.
Yes I can see the black header on the PCB, marked as you say.
I have some male plugs that will fit in the connector on the Hyperpixel.
I can do soldering so I can make a cable to fit.
I have yet to try the software to use the alternate i2c.


John A Jebb

The Hyperpixel is a nice bit of kit. It using all the GPIO is a bit of a bummer though, for me it is anyway. I almost always have something connected to the GPIO. There always seems to be some kind of tradeoff with Pi stuff.
I have two of the Pi Foundation 7 inch touch screens. They use the DSI connector and leave the GPIO all alone. The 800 x 480 screen resolution is a bit of a let down but that’s how things go sometimes.

I am about to re build the pi and the hyperpixel without any i2c i/o modules.
I wil then extend the connector on the hyperpixel to the i/o modules. I will also need to extend
the 5 volt rail to the modules, but I have worked out how to do that.

When I have done all this, will I need to re-enable the i2c support in the pi config? It is not enabled at the moment.
John A Jebb

I wouldn’t enable it unless you have to to get things working. just do the symlink thing and see what happens.
sudo ln -s /dev/i2c-3 /dev/i2c-1

OK I will let you know what happens,

As you advised earlier, I have made a connector to use the alternate port on the back of the Hyperpixel4 and I now have a working image on the screen.
The I2C driver is disabled in the R Pi.
I followed the instruction on how to use the alternate i2c, as below.
I have entered the command sudo ln -s /dev/i2c-3 /dev/i2c-1
The pi accepted it and the HyPix4 still works, but i2cdetect -y 1 and i2cdetect -y 3 do not show any devices on the bus. These commands produce messages as if they are looking for files that do not exist.

What are these /dev/i2c-3 and /dev/i2c-1? If they are files they do not exist on my system, according to File Manager…

Can you suggest anything else?

John A Jebb

That I don’t know unfortunately. My Linux skills are Noob level at best.

EDIT: i2c enabled or disabled in Raspberry Pi config? If disabled you could try enabling it, and hope it doesn’t break the screen working.

Thanks for the quick reply.

If I enable i2c in the pi config, the image immediately fades out.
If I disable it again it does not re-appear.
If I then re boot the pi the image returns to normal.

When the image is working,
If I enter sudo i2cdetect -y 7 I get letter UU at address 5D.
All other numbers except 7 report no such file or directory.


Ok, I seem to remember getting that same error message when running i2cdetect -y 1, when i2c hasn’t been enabled. My suggestion to turn i2c on was just a shot in the dark if I’m honest.
Maybe Phil @gadgetoid or Sandy @sandyjmacdonald know what’s going on?

Another option is to use the following link to contact Pimoroni tech support by e-mail. I’d put a link to this thread in it if you go that option

OK I will try that link to Pimoroni.

The reason I want to use that particular type of ADC is that it is 18 bit (highly accurate). I also need a few switch (digital) inputs and a few relay outputs.
Does Pimoroni do any products that provide this and will still work with the Hyperpixel?


Pimoroni have several automation hats, they won’t work with the Hyperpixel though.
You can’t use anything else that plugs into the GPIO with the Hyperpixel.
Check the pinout link I posted above, it uses “every” pin.