HyperPixel 4.0 non-touch shows desktop for a moment, then screen goes black

Hello.

I purchased a HyperPixel 4.0 non-touch from Adafruit and I did everything that the repo says (one-liner, checking the i2c device which is 11 in my case and link it to i2c-1) and I cannot make the screen work as it should be. When the Pi boots I can see the desktop for a moment and then it is all black screen.

I’m using a Pi400 with an Adafruit CyberDeck but also tested the screen on a Pi 4 8GB and it’s the same (same SD by the way).

Any help will be highly appreciated.

Here’s my debug information:
pi@raspberrypi:~/hyperpixel4 $ ./hyperpixel4-debug.sh

Platform Information

Revision : c03130
Description: Raspbian GNU/Linux 10 (buster)
5.10.17-v7l+

Touchscreen logs

Rectangular: Goodix
[ 5.943507] Goodix-TS 11-0014: supply AVDD28 not found, using dummy regulator
[ 5.943911] Goodix-TS 11-0014: supply VDDIO not found, using dummy regulator
[ 5.944725] Goodix-TS 11-0014: i2c test failed attempt 1: -6
[ 5.984442] Goodix-TS 11-0014: i2c test failed attempt 2: -6
[ 6.033794] Goodix-TS 11-0014: I2C communication failure: -6
Square: ft5

I2C Devices and Mappings

/dev/i2c-1
/dev/i2c-11
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –

Boot Config

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable infrared communication.

#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

[pi4]

Enable DRM VC4 V3D driver on top of the dispmanx display stack

dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

dtoverlay=hyperpixel4
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6

Do you actually have a device connected to i2c?
And if yes, is it connected to the i2c header on the back of the Hyperpixel?

The Adafruit CyberDeck is connected to the PI400 and then the screen connected to that cyber deck.
Tested connecting the screen directly over the GPIO on a Pi 4 8GB and it’s the same.
Safe to say, I have another HyperPixel (with touch) that my kiddo accidentally damaged (dropped) and that’s why I purchased this new one (non-touch version to save money).

If your not connecting anything else don’t worry about i2c. And if you enabled i2c that may be what’s messing things up. The Hyperpixel uses all the GPIO pins and repurposes them, including SPI and i2c. Leave those disabled when running the Hyperpixel one liner.
Even if your going to use i2c, don’t enable it in Raspberry Pi Configuration. The Hyperpixel uses a software i2c to get around the actual i2c being used for other things.

Hyperpixel4 at Raspberry Pi GPIO Pinout

Thanks. It seems the screen is DOA and I’m gonna get a replacement.