Inky PHAT gives missing EEPROm error

I have just received an inkyphat from my brother who could never get it to work. (The hat has also travelled from Sheffield on sea - to Claire Australia and back to Leicester)

I have installed and updated Buster, updated all the latest drivers etc.
The examples seem to hang in the function.

If I run python3 I get the following

from import auto
Traceback (most recent call last):
File “”, line 1, in
File “/usr/local/lib/python3.7/dist-packages/inky/”, line 44, in auto
raise RuntimeError(“No EEPROM detected! You must manually initialise your Inky board.”)
RuntimeError: No EEPROM detected! You must manually initialise your Inky board.

Is this an error ?

So I then tried to follow the manually commands as follows
from inky import InkyPHAT

def main(args):

return 0

and get this
File “”, line 27, in main
TypeError: set_image() missing 1 required positional argument: ‘image’

Confused as to what is going on and what to try.
Any ideas on what to try?


I got it to work by following Sandy post off the learning website, it looks like the display is broken, the first part does not update correctly,