Inky pHAT not changing from shipped image

Hi, I’m having trouble getting my Inky pHAT to change from the inkyphat image

When I run the provided example code for the Inky pHAT on a raspberry pi 3b I get the response

python3 --type "auto" --colour "red" --name "Inigo Montoya"
Inky pHAT/wHAT: Hello... my name is:

Use Inky pHAT/wHAT as a personalised name badge!

Detected Red pHAT (SSD1608)

Debug that may be useful

pip3 show inky
Name: inky
Version: 1.3.2
Summary: Inky pHAT Driver
Author: Philip Howard
License: MIT
Location: /home/pi/.local/lib/python3.7/site-packages
Requires: numpy, smbus2, spidev

SPI and I2C are both enabled, I reseated the ribbon cable and the hat looks to be connected correctly

How did you install the software for it? If I remember right there was some oddness where software was updated and then the old version caused problems for people. Perhaps try the install method here: GitHub - pimoroni/inky: Combined library for V2/V3 Inky pHAT and Inky wHAT.

I installed using pip3 on that page, it looks like my version matches the latest release but it still doesn’t work

In that case, you best bet might be to email Support[at], or @ some of the developers here.

After reinstalling Raspberry pi os on my pi and going through all the steps again it worked.

No idea why but very happy :)

Thank you for your help