Inky pHAT Not Working: Display Not Changing

Hello all, I’ve been trying to get my red/white/black Inky pHAT to work ever since I’ve got it. I am unable to change the display at all, and feel like I’ve tried all that I could based on other forum posts and various tips. The display will not change with any of the example scripts or any custom scripts I use.

I have tried all of the following with a Pi Zero W and a Pi 4:

-ran all example scripts, shows (seemingly) successful messages. For Example, when running

python3 --colour “red”
Inky pHAT: Calendar

Draws a calendar for the current month to your Inky pHAT.
This example uses a sprite sheet of numbers and month names which are
composited over the background in a couple of different ways.

Detected Red pHAT (High-Temp)

-used 3 different SD cards with both lite and normal versions of Raspian
-reseated the ribbon cable on the pHAT
-running sudo pip install --upgrade inkyphat to upgrade the software
-upgrading and updating Raspian w/ sudo apt upgrade & sudo apt update

And of course trying all of these things multiple times to see if I missed a step. Please, I would love to not have to spend another $25 on one of these things if I don’t have to. I must be missing something, or have killed my pHAT somehow.

Thank you in advance for any input on this issue!

Just to confirm, you ran
curl | bash
Instead of pip, try using pip3.
pip3 install inky[rpi,fonts]
pip3 install inky

So, the examples run as normal without error, but nothing is displayed on the ink?
I would double check that i2c and SPI are both enabled in raspi-config. It looks like it uses both. i2c for detetction of which inky it is, and SPI to actually draw the image on it.
Inky pHAT at Raspberry Pi GPIO Pinout

Inky firmly attached to the GPIO header?

thanks for the super quick reply!

Blockquote Just to confirm, you ran
curl | bash
Instead of pip, try using pip3.
pip3 install inky[rpi,fonts]
pip3 install inky

Ran all of the above, yes. Tried pip3 instead on a fresh install as well.

I also ensured that SPI and i2c are enabled in raspi-config. Inky firmly attached to GPIO header.

Yes, all examples run without error, the screen just doesn’t display anything. Here’s the output for example:

python3 --type “auto” --colour “red” --name “Inigo Montoya”
Inky pHAT/wHAT: Hello… my name is:

Use Inky pHAT/wHAT as a personalised name badge!

Detected Red pHAT (High-Temp)

I don’t own one so there isn’t much more I can do.
You could use the contact us link on the shop page to e-mail Pimoroni.
I’d put a link to this thread in that support e-mail
Contact Us for Raspberry Pi Technical Support – Pimoroni