Inky pHAT doesn't update display

Hi, I just got time to play with my new Inky pHAT.


  • Attached to a Raspberry Pi Zero W;
  • Software is installed ( curl | bash ), BTW, the check_network which ping doesn’t work on my Pi, so I just simply commented the line and force it always return 0. Actually I think that could be removed, since if the curl works, there must be a network connection.


  • Followed the getting-started-with-inky-phat tutorial;
  • Go to cd /home/pi/Pimoroni/inkyphat/examples;
  • Run python (also tried and;

The python script outputs like below:,

$ python
Inky pHAT: Calendar

Draws a calendar for the current month to your Inky pHAT.

This example uses a sprite sheet of numbers and month names which are
composited over the background in a couple of different ways.

# after a few minutes
Shutting down display, please wait...

And the Inky pHAT display never get updated (always displays the same image which came after unboxing).

Could anyone help me to troubleshoot it please? Thanks in advance.

How can I check if the Inky pHAT is well connected? And if the hardware is not damaged? Should I check GPIO status?

I wont rule out that there could be something wrong with the Inky pHAT, but since it must have worked to get the original image on there my first port of call would be to check the Zero W itself and any other software that might be running.

Have you installed any other libraries/examples or run any code for any other add-ons on your Zero W?

Could you post a picture of your header soldering on the Zero W?

Thanks @gadgetoid, I’ll check my soldering first.

@gadgetoid it’s working fine and does respond to command.

The only question is: during updating display, the screen blinks a while before displaying the finally picture. Regarding the blinking, I mean only the certain area / shape which needs to be re-render to a different color blinks. E.g. if there is a star, before painting the area was white, then the star shape goes black first, then red. Just filled in with color step by step. Is this normal?


yes, that is how it works: each ‘colour’ is layered one after the other.

@RogueM cool, good to know that, thanks a lot :)

Sorry for bumping this old conversation, but I have the same problem as in the top post.

All examples runs without errors nor exceptions, with expected log outputs etc. I’ve enabled all interfaces, and installed the latest version of the library without any trouble. The display is simply stuck on the original image, no matter what.

I’m running with RPI zero w, I’ve tested it with another RPI zero w with the same (non-existant) result. I’ve also tested with different GIPO pins etc but no cigar.

(I have not soldered my InkyPhat onto the rpi 0, since I’m not good at it. If it was neccessary I did not want to solder anything before checking the inky anyway.)