Inky pHAT not displaying properly

Hi everyone! I’m new here and was super excited to use the Inky pHAT for a project I’ve been planning for a while now. However, I’ve had issues getting my yellow Inky to display properly. It looked fine out of the box but I’ve tried all the test scripts and they run but the pHAT won’t properly display any of them nor will it fully clear when I run the example. (See weather screen below.)

I’ve tested on two different Pi’s (Zero and 3 Model B) both through wiring the Pi with jumper wires and putting it directly onto the headers. Has anyone else had similar problems? I’m hoping it’s not something wrong with the pHAT but I’m out of ideas on what else to try.

Thanks in advance for any help!!

How did you install the Inky library? There have been problems with that in the past, although I don’t think I’ve seen anything like this.

If you flip the board over, how does the copper-coloured ribbon cable look? It should be fairly straight and paralell with the edges of the board, like the product photos.

I installed the library via:

curl | bash

The example scripts have been running - no runtime errors or anything. But the board doesn’t seem like it updates properly. For example in, the screen doesn’t fully flush to blocks of the different colors (that’s what I was expecting but maybe that’s wrong).

I’m no expert but the ribbon seems more or less normal. See picture below:

Hmm, I’m hardly an expert but all of that looks fine to me. It might be time to contact Pimoroni about a replacement: