InkyPHAT not displaying anything

Hello,

I bought an InkyPHAT Yellow which seems to be a SSD1608 and I encounter some difficulties to use it.

I tried with 2 Raspberry Pi :

  • A RPi Zero W
  • A RPi 3B
    And the problem is the same.

The script “name-badge.py” run without problem but there is no screen update.
I installed an GPIO monitor and it appears that during the update, some data are send threw the PIN 10 and 11, so it doesn’t seems to be a software problem.

The weird thing is that the first day of use, the screen worked and I could :

  • Run name-badge once
  • Write some texte on screen as described on the getting started guide
  • Run the clean script

But sinced the next day, nothing worked.

Another weird thing is that my device seems to be incorrectly detected : I bought a yellow screen and it was shiped with the yellow logo display.
But when I run auto, the function returns Black pHAT SSD1608, when I run inky.eeprom.read_eeprom, it returns yellow with 212x104 screen size (so different than the SSD1608 dimension).

I’m kinda desperate to make it work.
I’m starting to think that this is an hardware problem.
Is there something I’ve missed ?

Thank you