PI 4B not detecting InkyPhat Yellow

Hello.
I got a brand new InkyPhat Yellow a few days ago, and have tried to set it up since.
The installation of the “all in one” script completed without any problems, but when i try to run any example it just gives me a message like this:

sudo python3 name-badge.py --type “phat” --colour “yellow” --name “My Name”

Inky pHAT/wHAT: Hello... my name is:
Use Inky pHAT/wHAT as a personalised name badge!
Failed to detect an Inky board, you must specify the type and colour manually.

i2cdetect -y 1

    0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- -- 1a -- -- -- -- -- 
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --   

sudo pip show inkyphat

Name: inkyphat
Version: 1.0.1
Summary: Inky pHAT Driver
Home-page: http://www.pimoroni.com
Author: Philip Howard
Author-email: phil@pimoroni.com
License: MIT
Location: /usr/lib/python3/dist-packages
Requires: spidev, RPi.GPIO, numpy, pillow
Required-by: 

I am running Dietpi and i have the case argon ONE V2, with a gpio ribbon cable (the inkyphat can’t go in without it)
I have tried reconnecting the board several times, made sure it was pushed all the way in, i tried reconnecting the cable on the back of the inkyphat and checked for shipping damage.
I am not sure what more i can do, and is not hoping for a hand from the forums.

Try --type “auto” instead of --type “phat”

Thanks for the reply.
When i try with auto it give me this error message

sudo python3 name-badge.py --type "auto" --colour "yellow" --name "My Name"
Inky pHAT/wHAT: Hello... my name is:
Use Inky pHAT/wHAT as a personalised name badge!
Failed to detect an Inky board, you must specify the type and colour manually.
usage: name-badge.py [-h] --type {what,phat,phatssd1608,impressions,7colour}
                 [--colour {red,black,yellow}]
name-badge.py: error: argument --type/-t: invalid choice: 'auto' (choose from 'what', 'phat', 
'phatssd1608', 'impressions', '7colour')

Ok, it was a shot in the dark if I’m honest. SPI enabled?

In the config the state of SPI is on

I don’t own an Inky, just so you know.
Are you running it in Python 2 or Python 3?

I’m currently running it with Python 3, but tried with Python 2 yesterday.

How hard would it be to plug the Inky right into the Pi, without the ribbon cable?
Do you have a spare Pi to try it on?

Did you run curl https://get.pimoroni.com/inky | bash
or pip3 install inky[rpi,fonts]

I used the curl https://get.pimoroni.com/inky | bash command.
I think i can get another Pi 4 and a Pi Zero WH in a few days i can test it on.

Ok, curl should have installed everything needed. I don’t think it will hurt anything if you also run pip3 install inky[rpi,fonts]
Pimoroni is going to ask you to connect it directly to a Pi to rule out an issue with the ribbon cable. You could post it as an issue on github while you wait for another Pi to arrive. These days I almost always add a Pi Zero to any order I place, just to have a spare Pi to tinker with.

I tried with the pip3 you recommended and got Requirement already statisfied on everything.
I will open an issue post on github, and test with the new Pi when i get it.
Thanks for the help so far i really appreciate it.

Looks like you’re using the old library (inkyphat) not the new library (inky).

Newer variants of the inkyphat are not supported by the old inkyphat library.

You may not have run curl https://get.pimoroni.com/inky | bash, or you’ve previously installed the software?

Read this carefully: Inky pHAT EPD Display for Raspberry Pi – Pimoroni

When i installed the library was i using the same website you are linking to, i checked my “command history” on the pi and it is the same command as the one you mentioned.
I don’t have any previous installation of the software.
Fingers crossed it will work on the extra Pi when it arrives.

This is the old library. It won’t work with your pHat.

Can you share exactly what it is you are trying to run? It is possible to have both libraries installed at the same time. Maybe you have the old examples (which use the old libraries) too.

What happens if you run identify.py from the examples?

On installation i did

curl https://get.pimoroni.com/inky | bash

Then after installation and reboot i tried changing directory to the examples directory and tried the name-badge.py both with type as auto and phat, with and without sudo.
With type auto it ask me to select type and colour manually, and with phat it just can’t detect any inky board.
sudo python3 name-badge.py --type "auto" --colour "yellow" --name "My Name"

When i try to run identify.py i get the following

No display EEPROM detected,
you might have an old Inky board that doesn’t have an EEPROM - eg: early Inky pHAT
boards.
Try running examples with --colour <black/red/yellow>
Or writing your code using:
from inky.phat import InkyPHAT
display = InkyPHAT("<black/red/yellow>")

I just looked at your i2cdetect - both my older red pHat and my newer yellow pHat show up as address 50

Do you have any other peripherals connected?

The 1a that i2cdetect show if i am not completly wrong, is used by the Argon ONE MCU that my argon ONE V2 case have, but it’s not directly connected to the GPIO pins. All the GPIO pins should still be accessible as shown on this picture.

It may be just possibly worth trying it with the 4 out of the case. Just in the unlikely event that something is messing with the I2C bus.