Brand New Inky PHAT Yellow not working

Hi I have a brand new Inky PHAT in Yellow and can’t get it to work. I installed as per the instructions and tried to run the name badge example but get “Failed to detect an Inky board, you must specify the type and color manually”.

I specifed them manually trying various options but then I get the error all the time

"Failed to detect an Inky board, you must specify the type and colour manually.
Traceback (most recent call last):
File “name-badge.py”, line 18, in
inky_display = auto(ask_user=True, verbose=True)
File “/usr/local/lib/python3.7/dist-packages/inky/auto.py”, line 19, in auto if args.type == “phat”:
AttributeError: ‘tuple’ object has no attribute ‘type’.

I am disappointed as there seems to be multiple complaints with the Inky PHAT not working and no replies in the forum. I have tried on a Pi Zero 1.3 and also new Pi 4 both with the same results.

Does anyone have any suggestions as how I can get this to work?

I tried one of the other examples and get the same error. I tried the python to print “Hello World” but nothing happened on the display and no errors.

Thanks in Advance

Andy

One option is to post it as an issue on its github page.

Thanks somehow I got it working without some of the arguments just running say python3 name-badge.py --name “Andy”. Now to see what else I need to change to get other examples running! Seems like the color isn’t needed anymore? It registered mine as “BLACK” but still displayed in Yellow. Will check out GitHub as well, cheers.

I “think” they are trying to make it the one software install for all Inky’s. And for you not to have to specify which one you have? Something like that but its either a work in progress or something got glitched in the process. That’s my best guess as I don’t have any affiliations with Pimoroni.

My advice is to make notes on what you changed and what works and what doesn’t. If you don’t, a year or so down the road when you start over you’ll wish you had. ;)

1 Like