Inkyphat - not working

I’ve checked the forum and there are a bunch of reports like this but nothing seems to help :(

I have the same symptoms as

The phat appears to be seated properly, and I’ve tried a couple of different Pis incl a Pi 3B and a Pi Zero W 1.1. I have two inkyphats (Yellow), tried both.

i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
50: 50 -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --                      

So it looks like the phat is detected?

Not sure how to diagnose further.

Version:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster

InkyPhat installation:

$ sudo pip show inkyphat
Name: inkyphat
Version: 1.0.1
Summary: Inky pHAT Driver
Home-page: http://www.pimoroni.com
Author: Philip Howard
Author-email: phil@pimoroni.com
License: MIT
Location: /usr/local/lib/python2.7/dist-packages
Requires: RPi.GPIO, pillow, spidev, numpy
Required-by:

Command execution / output

~/Pimoroni/inky/examples$ ./name-badge.py --type phat --colour yellow --name Christian
Inky pHAT/wHAT: Hello... my name is:
Use Inky pHAT/wHAT as a personalised name badge!

But nothing changes on the display, also tried clean.py

As I say two InkyPhats (both bought last week) and a few different Pis.

Any thoughts?

The inky uses SPI, not i2c. i2cdetect isn’t going to see it.
Double check that SPI is enabled.
PiOS Lite or the with Desktop version?

Thanks for the answer, understood. SPI and i2c are both enabled.

Desktop version, but running in console mode only.

$ ls /dev/spi*
/dev/spidev0.0 /dev/spidev0.1

Ok, I asked what version because the Lite version is missing things that are in the “with desktop” version. This can cause problems with missing dependencies etc.
I’m at a lose as to why your inky’s don’t work?

1 Like

Is there a way I can somehow get debug / diagnostic? Or can I multimeter something on them to see what’s happening? I’ve tried reseating one of the ribbons as well (not both in case of additional b0rkage)

That I don’t know? My Linux skills are noob level.
What command are you using to run the python files?
Python 2 or python 3?

Just executing the default so python-2.7.16

sudo python /etc... ?

Yeah not a perms issue - the thing runs fine and doesn’t throw any errors, and exactly the same result under sudo

About the only other thing I can think of to try is boot to desktop and run the file from an IDE like thonny. I prefer idle myself, but you have to manually install it now.
That might get you a message to clue you in to what is going wrong?
I don’t own an inky, just so you know. ;)

1 Like

Any luck yet with your phat? You’re not alone.

No unfortunately not, I’ve given up - two Phats, many different Pis, nothing ever happens on the display.

I’ve reached out to support.

If your using anything other than a Pi 4B, you could try Jessie and see if its just a Buster issue.
http://downloads.raspberrypi.org/raspbian/images/

I might do. Hopefully someone from Pimoroni support has experienced this before and can advise.

I used the contact us link on the main page to e-mail tech support. I put a link to this thread in it. There are a few other similar posts on this.
I think the proper way, or at least one way to report this is to file an issue on the GitHub page.

Filing a github issue is a good idea, and I can see babelmonk has a ticket on the go at the moment so if we can’t fix it there we’ll get them back and see if we can find out what’s going on with this. @shawkes if you could also email support we’ll take a look there as well?

1 Like

Updated https://github.com/pimoroni/inky/issues/57 with more details, tested now with stretch from clean install as well as buster.

Resolved and fixed. tl:dr; need to update to latest for newest chipset on the inky and update examples as well (see GitHub issue linked above for details) - great support - thanks Pimoroni folks!

That’s great news, now you can enjoy your new inky. =)

1 Like