PI 4B not detecting InkyPhat Yellow

So i got the new PI4, did a fresh install, no special case.
When i run it with auto it still ask me to select a type and when i then select phat it gives me a new error.

Failed to detect an Inky board, you must specify the type and colour manually.
Traceback (most recent call last):
File “calendar-phat.py”, line 199, in
File “/home/dietpi/.local/lib/python3.7/site-packages/inky/inky.py”, line 346, in show
self._update(buf_a, buf_b, busy_wait=busy_wait)
File “/home/dietpi/.local/lib/python3.7/site-packages/inky/inky.py”, line 261, in _update
File “/home/dietpi/.local/lib/python3.7/site-packages/inky/inky.py”, line 228, in setup
self._gpio.setup(self.dc_pin, self._gpio.OUT, initial=self._gpio.LOW, pull_up_down=self._gpio.PUD_OFF)
RuntimeError: Not running on a RPi!

I see dietpi in there. If that is what your running I’d try the official PiOS. That’s what the Pimoroni installer and software is written for.

I listened to you advise and tried a clean installation of PiOS, but unfortunately i still get the same messages with and with riser cable.
type auto = select type
type phat = Failed to detect an Inky Board.
So i am starting to think i could have gotten a defect board, but i am not sure.