IoT phat guide?


#1

I would really like to start playing with the esp8266 phat. Problem is I have absolutely no clue what to do! From what knowledge I do have I think this would be incredibly useful for my projects, home automation using mqtt with home assistant.io. NodeMcu is…well not for me so this board, particularly as it’s with the rpi seems perfect. If I could use it! I know it has been mentioned that guides and Python support etc is in the pipeline but nothing seems to have materialised as of yet? Any help or pointers would be greatly appreciated! As a side note, I looked at the getting started blog linked on the product shop page and I’m not sure if it’s me or if something has changed but I get so far before I hit a dead end? I open minicom but can’t type or do anything? Thanks in advance for any assistance offered.


#2

have you disabled the serial console?

if in doubt, you can run:

curl -sS get.pimoroni.com/iotphat | bash

and it will do it for you (as well as install minicom, though it seems you’re covered on that front).

Not sure about python support, but a custom firmware was talked about a while back, but you can use the Espressif one or flash whichever works for you.

The best place to find ideas and practical applications is at http://www.esp8266.com/

I suspect they’ll be a learning article at some point, I’m certainly contemplating doing one once I got what I’ve got on my desk cleared up.


#3

Yep double checked serial console. incidentally after running curl -sS get.pimoroni.com/iotphat | bash, now when I attempt to open minicom, nothing happens at all? even done a fresh Raspbian install and same outcome? One thing I have noticed is that in /boot/cmdline.txt before any editing the content is :

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

yet all information is to remove ‘console=ttyAMA0’ which clearly isn’t there to remove?
Other than that I am lost. Nothing I can read or try seems to make any odds.


#4

I can get in with sudo minicom and I am confronted with:

Welcome to minicom 2.7

OPTIONS: I18n
Compiled on Jan 12 2014, 05:42:53.
Port /dev/tty8, 12:19:37

Press CTRL-A Z for help on special keys

All I can do is Ctrl AQ to quit though!!
Time to walk the plank me thinks lol!!


#5

hum, editing /boot/cmdline.txt would be the last thing I’d do as what’s relevant there is quite dependent on the Raspbian version and Pi model you are using.

Talking of which what Pi are you using :D


#6

after checking against the lastest Raspbian image, yep, seems like a lot has changed since I last checked…

Anyhow, in /boot/cmdline.txt, you should see something like:

console=serial0,115200

… take it out

Then, if you are on a Pi3, add the following to /boot/config.txt:

dtoverlay=pi3-disable-bt

note that this last part will disable Bluetooth on the Pi 3, there’s an alternative overlay that will switch BT to the mini UART interface, but it may take additional efforts to get it up and running… YMMV.