Is my WS2812/SK6812 strip DOA?

Howdo. I’ve received my “Flexible RGB LED Strip (NeoPixel/WS2812/SK6812 compatible) - 144 pixels per metre” strip but can’t get it to light up at all. The only microprocessor I have to hand is an ESP8266 based Wemos D1 Mini Pro. Anyone any pointers as to how I can test the strip as its giving all impressions of being DOA.

The current setup is broadly inline with the adafruit recommended setup:

Breadboard 1: Power to Strip:

  • 5V/2.4A PSU via USB breakout to +5V (red) line on the strip.
  • 5V/2.4A PSU via USB breakout to GND to strip (white), also bridged to GND pin on the Wemos.
  • 1000µF 6.3V Capacitor bridging +5V and GND.

Breadboard 2: The Wemos D1 Mini Pro

  • Common ground with strip via GND pin per above.
  • 5V and GND coming in via USB connector from PC.
  • GPIO4/D2 connected to DATA line of strip (green) via a 470Ω resistor.

I am running a modified version of the adafruit test-neopixel-strip sketch amended for pin D2.

I can’t make the strip light up at all. I’ve checked that the arrows are going the right way on the strip, and that the supply voltage is stable at 5V. Both are fine.

Feel like I’m missing something. The data path to the first LED is around 6 inches, and though I’ve seen it suggested that a logic level shifter is required for stability, I’ve seen many others getting this working for a short run without it, and many who say its empirically not necessary. I’ve been careful to connect GND first, then +5V, then data. If the data voltage isn’t high enough, would it all be dark like this?

Anyone got any pointers at all? I only need 18 leds to get this project working, and am stumped as to why I can’t get any life out of the strip when others seem to succeed. Is there any other way to test it?

Things I’ve tried

  • The sketch (added via ArduinoIDE version: 2.0.0-rc7/CLI Version: 0.23.0 - 899dc91b) compiles fine.
  • Connecting via serial at a timing gentle 115200, shows no issue with the loop.
  • Running the board from the same PSU so as to avoid any serial conflict makes no change.
  • Measuring the voltage on the socket at the other end of the strip shows a 5V differential between red and white, as expected.

Ok. Pretty sure I’ve solved that one.
Removed the resistor on the data line, and everything is happy.