Is the fault with Lipo or powerboost charger?

Have recently received the kit below.

Battery won’t charge and I can’t get 5v out of the powerboost charger.

Yellow charging light comes on. Red discharged light flickers very briefly when battery first attached.

Voltage across the battery is 4v when I put my meter across it (and nothing else) but falls to around 0.1v - 0.2v when connected to the charger.

Not sure if the charger or the battery is faulty. Need this urgently working for close of play on Tuesday if at all possible.

Ideas gratefully received - especially narrowing down whether this a problem with battery of Powerboost board. Thanks

LiPo Battery Pack - 500mAh
PowerBoost 500 Charger - Rechargeable 5V Lipo USB Boost Adafruot

Can only attach one photo as a newbie unfortunately.

It looks to me like the battery polarity is reversed at the jst jack,

Thanks - but I think not.

Are you sure the white usb cable is a Power cable ,some are only data ,I had a power boost 500 that just stopped for no apparent reason .that I’ll admit to anyway ;)

Thanks for the suggestion. Have tried multiple cables and chargers. The fact that the orange charging LED lights when power connected implies that the charger is getting power.

Ok, I was looking at the PowerBoost 1000c page which for some reason had me thinking it was reversed. The JST jack on the 1000c is in a different position, and doesn’t have the + on the board.
Looking at the correct product picture shows me yours is connected properly. Sorry about that.

The Blue Boost LED never turns on?

Blue light turned on when I first tried the battery. Until the battery became first discharged.

No worries - thanks for the suggestion.

How long have you left it charging the battery? I have several powerboost 1000c 's kicking around here, no 500c’s though. It can take a while to charge especially if its really low, or a high capacity battery. The Yellow LED “should” eventually switch to a Green one.
My Boost section runs even when the battery is being charged. I use the Enable pin to turn it off if all I want to do is charge my battery. I have a 6600 MAH battery on one of mine. I needed a long run time.
It does sound like something isn’t working as it should.

What are you charging from? A Raspberry Pi Power Supply works well with these. A stock USB 2 port can only supply 500ma max, That’s not a whole lot these days.

I left it several hours. I’m not getting any power out of the device to power my circuit whilst the device is charging - which is not what the powerboost is supposed to do. That implies the problem is with the powerboost and not the battery The only reason I don’t know for sure that the powerboost is faulty is that the FAQs say it won’t work without a battery attached.

A wall charger rated at 1.5A

OK, I’d say its faulty then. You can e-mail Pimoroni via the following link. I’d put a link to this thread in that support e-mail.
Contact Us for Raspberry Pi Technical Support – Pimoroni

I am sure either the powerboost or the lipo is faulty. But which?

That I don’t know? You’d need a second LIPO or another PowerBoost to sort it out.

Just curious what the load is? Is 500ma going to be enough?

The project is an arduino powered CO2 detector - load will be no more than 100mA peak when the NDIR sensor is warming up - I’m a part time physics teacher and I want to measure the CO2 levels in my classroom as the windows don’t open and I’m very concerned about air quality. I’m hoping to get it working for my first lessons on Wednesday but if Pimoroni don’t respond soon that’s not going to happen,

Ok, a working Powerboost 500 should be more than enough for that. I asked because I have a couple of builds that are iffy for a 1000c. I actually switched to a 1000 basic and a separate LIPO charger for one portable setup. The 1000c is only good for about 1A out but the basic can do 2A out. I have a Unicorn HD, LED Shim, several environmental sensors, and a Pi Zero in a portable case. I was getting an occasional undervolted warning when on battery power only.

1 Like