Issue with Enviro+ with RPi Zero: Display and particles not working

I just setup a new Raspberry Pi Zero with an Enviro+ and had the issues above and this fixed it for me. Thanks

1 Like

In all cases, knowing the output of /proc/device-tree/model and gpioinfo (might need to sudo apt install gpiod) would be useful for adding explicit support for older Pi’s.

I wonder if adding a row simply for Raspberry Pi copying the Pi 4 pins would work across all previous boards. I’ve raised the pin-names-being-different-between-boards issue upstream with Pi and there’s still some uncertainty about how to deal with that.

Sorry for throwing a curveball here. The switch to libgpio has been… dicy. Trying to get it done right and trying to get it done fast are mutually exclusive. I had to take some time off over Christmas, but I’m getting back on this now.

(was tipped off about this thread by a comment on Port to gpiod and gpiodevice · pimoroni/pms5003-python@77d1e34 · GitHub - thanks)

In all cases, GitHub is the best way to raise any issues, input, comments or join me in screaming into the void, currently there are a few relevant places for this tumultuous transition-

Hey all,

Like suggested here in this topic, I uninstalled newer versions of pms5003 and st7735 and installed specified versions but I’m getting this error:

2024-04-08 22:33:00.458 WARNING  Main Loop Exception: PMS5003 Read Timeout: Failed to read start of frame byte

this line keeps appearing over and over and the lcd screen shows colorful grainy, noisy pattern. Using Zero W with Debian Bullseye (2024-03-12). Also tried it with Zero 2W and the result was the same.

I also tried sebgus’ way of modifying init.py in pms003 package but that method showed me another error on Zero.

Any progress on the fixes?

Withot a working software, this module is just paperweight.

I think Pimoroni requires this disclaimer on their product page: “The software package we put together doesn’t work anymore due to some changes in libraries and users required find a solution on their own”.

Because currently, under software headline, the wording create the illusion of a easy to setup & plug and play environment created by you, which is not true and is deceptive.

Sorry to hear you’re still struggling!

Have you tried starting from fresh with a new image of Pi OS Bookworm and a fresh pull of the library? We’ve now merged in all the updates to accommodate the new GPIO libraries and updated our Learn guide so things should hopefully now be in a less confusing state than they were back in April.

If you’re still having problems getting things working please let us know the exact text of the errors that you’re getting and we’ll see if we can help further.