Microdotphat Pi Zero Error


3 days ago i bought my first raspberry Pi - Zero W. i installed the operating System, connected to my WLAN and access via remote to my Pi.
Now i want to start the microdotphat. I installed the libary and wanted to start the first example.
I opened the terminal and wrote the following command:

Triton@raspberrypi:~/Pimoroni/microdotphat/examples $ sudo python flash.py

Each time i did this i get following answer:


Flashes all the elements.

Press Ctrl+C to exit.

Traceback (most recent call last):
File “/home/Triton/Pimoroni/microdotphat/examples/flash.py”, line 19, in
File “/usr/lib/python3/dist-packages/microdotphat/init.py”, line 323, in show
File “/usr/lib/python3/dist-packages/microdotphat/init.py”, line 386, in setup
_n1 = NanoMatrix(address=0x63)
File “/usr/lib/python3/dist-packages/microdotphat/matrix.py”, line 61, in init
self.bus = smbus.SMBus(1)
FileNotFoundError: [Errno 2] No such file or directory

It is the same thing with each example. I also tried to write a new programm, And i tried to start the example from the explorer. i get the same error message in every constellation. Have you an Idea? Thank you!

Double check that i2c is enabled.

1 Like

Thank you really much. That was the problem. :)

I was hoping you’d say that. That error message is a bit confusing, until you’ve seen it once or twice.