Motor 2 controls don't work


#1

I am using the explorer phat with a raspberry pi 0 w, with the latest rasbian stretch lite image.
I am relatively new to soldering, so my solder points might be sloppier than most.
When I drive a motor from the “motor one” output (via python explorehat module), it works fine.
However, motor two is dead. I checked and rechecked all my solder points and even resoldered a few particularly sloppy ones. Still no luck on motor 2. I’m starting to think the issue is not with the soldering.
Any tips / points on how to debug further or to resolve would be appreciated.

Thanks!


#2

I had a similar problem with a Zero W and Explorerhat Pro, Motor 1 was perfect, motor 2 would drive forwards but not backwards.
Try adding “snd-bcm2835” to /etc/modules and “dtparam=i2c=on” to /boot/config.txt. I also secured the Explorer hat pro to the Zero W with some nylon stand offs. It worked perfectly after that


#3

If you have a voltmeter, give it the command to run at full speed, then look for 5V across the motor terminals on the explorer pHat. If you get 5V there, check the motor terminals for 5V.


#4

Another option, if possible and if you haven’t already tried it. Is to switch the motors around. Connect motor 2 to motor 1 on the explorer pHat and motor 1 to motor 2. Then see what happens. That should tell you if its the motor or the signal from the explorer pHat.


#5

Thanks for the great suggestions, people! I did eliminate the motor as an issue, as well as the wires, by permuting the connections between the motors and the pins. I do not have a voltmeter (that would have been my next move…) - but I am definitely going to get one in short order. @lufbrarunner - your suggestion looks promising! Trying that now… :fingerscrossed:


#6

Thanks for the suggestion… but this did not work :sigh: I’m going to get a voltmeter to debug further. If the signals aren;t coming thru on the motor 2 pins, I am going to check the source pins on the pi - which per the docs are GPIO 21 and GPIO 26.


#7

A good close up picture of your soldering might help.


#8

https://www.evernote.com/shard/s135/sh/eaac24c9-1ad6-4d44-9a38-190181c19403/5bf224b60fcfcdc1f564ae2db1d10bc6


#9

I hate to be the bearer of bad news but IMHO that is a really bad soldering job. It can happen if you’ve never done it before or done it very little. It really needs to be redone and cleaned up. Have a look at this first, https://learn.pimoroni.com/tutorial/sandyj/the-ultimate-guide-to-soldering

Place the soldering iron tip so it touches the pin and the pad on the board at the same time. Wait a second, then apply a little bit of solder to the irons tip. Once it melts draw the iron away strait up. The pin doesn’t have to be covered right over the top. The base around the pad should be covered though. Something like this.

In your case, try remelting the existing solder so it flows right down around the base of the pin. Use a clean tip and don’t add any solder, you have a bit to much there now. Let your iron take some of it away, and clean your tip between pin fixes.


#10

Well (well, well :)). My multimeter just arrived, and I tested the output on the motor 2 pins on the pHAT. Guess what - solid 5V. Retested with actual motors, also solid. Not sure where I went wrong earlier - could well have been a wiring / contact issue between the header and the motors. Or gremlins fixed the solder points :)
So I feel embarassed and ecstatic at the same time. Thanks for your support / humor :) The adventure continues…


#11

any sense of what fixed this? i am having the same problem.


#12

You really need to redo and clean up your soldering job. Too much solder IMHO. I bet there are a few cold solder joints as well.