Need Help! Pimoroni Hyperpixel/Pihole Console blanking when I goto bed

I have a RPI4 that has a Pimoroni Hyperpixel 4, and its running PIHOLE in which the display is a FULLSCREEN TERMINAL window that runs stats…

Im not knowledgeable in this subject so I found the below info and did it to no avail… It I guess only works on a regular PITFT…
Below is the CODE to BLANK the screen ‘after hours’ but again it is for the original PI TFT…

Does anyone know how I can change a setting and redo this to work w/ a hyperpixel screen ? Links and code below… thanks !


Turn off the PiTFT at Night

The PiTFT is bright and doesn’t need to be powered-on at night, so let’s put it to sleep until we wake up.

Edit cron as root:

  1. sudo crontab -e

Select nano as an editor by pressing the 2 key.

Scroll beneath the commented text (#) and enter the following:

  1. PADD Sleep

  2. Turn off the PiTFT+ at midnight

  3. 00 00 * * * sh -c ‘echo “0” > /sys/class/backlight/soc:backlight/brightness’
  4. Turn on the PiTFT+ at 8:00 am

  5. 00 08 * * * sh -c ‘echo “1” > /sys/class/backlight/soc:backlight/brightness’

Save ( control+O ) the configuration and exit ( control+X ) nano to be brought back to the terminal.

Reboot the Pi to apply the new changes by running:

  1. sudo reboot

You can control the backlight brightness using Pin19, it’s a PWM pin and the lower the signal the darker it will get. You can do that through Python or there are example Bash commands here.