New Picade - thanks and a few minor problems


#1

First of all a big thank you for a nice surprise, considering the new Picade was supposed to ship in three weeks, and you managed to get me mine in three days. Sent to germany no less.

The build quality is really great for the materials used and the powder coating is done very well. The instructions on the back of a a poster is a nice little touch as well.

On to the small “problems”

The instructions say to finish up the control panel before installing the brackets on there, but the space between the stick and the bracket is way to small to get the nut in place and I don’t really have big hands or fingers. So installing the brackets first before the stick can save some time and nerves.

The second “problem” is with step 9, whre you are supposed to reach in from the back to hold the nut while you tighten the bolt, I really tried but for me it seems impossible with everything built in by the time you reach this step.

Now something more serious or better annoying:

One M3 screw was missing from the package, not a biggie but for those who don’t have a spare at home might run into problems, maybe putting one or two spares in the bag could compensate this.

One of the pink buttons “sticks”, when you press it it remains pressed until you literally pull it out, changed it out for a different button I had from an older arcade stick build I did, but it doesn’t look to hot having a white button in the “rainbow” ;)

Last and probably biggest problem, the control panel for the screen does nothing, don’t know if it is a software problem, but reconnecting the ribbon cable didn’t do anything and the buttons remains without function.


#2

This was extremely hard for me too, and something that should have been considered better in the design. I rested a nut on my pinky finger and then reached in with it, hoping I could align it on the partially screwed in bolt. It was hard as nails, but necessary for the sturdiness of the build. Was not a fun 20 minutes for sure.

Had this problem too with some buttons, until I lined up the two clips that get pushed in with the small recesses in the console holes, which solved the problem.

Same here! Maybe it’s a driver thing, or maybe the cable should be installed with the blue label inward, rather then up, despite instructions otherwise.

Now one thing I’ve come across is that when I put the back panel in place, there is a significant gap of a few millimetres at the top, in the right corner (looking at it from the front). Even though it gave it a lot of attention, I apparently didn’t manage to build it straight enough. How is this for you?


#3

Thanks for the tip, did the same thing yesterday after hitting submit on my post and yes this works fine, still I put some silicone grease on there for good measure.

I wouldn’t say a few millimeters but it is not completly flush with the rest of the case. I think this happens because of the cutout below for the (nonfunctioning) screen controls.


#4

Thanks for your feedback, @Erdnuckel0!

There will be certain bits of the build that work better slightly differently for different people. While doing numerous test builds we found the way we explained it in the instructions worked best for us (we had four or five Pimoroni crew build Picades during testing). Of course, if you find a way that works well for you, then that’s absolutely the best way to do it.

That last nut that needs to be tightened is always really fiddly. Two things we found that made it a little easier were: to pop the closest side button out temporarily and reach in through the hole, and to lay the cabinet on its side (the opposite side to the nut you’re trying to tighten) so that you can balance the nut on your finger while trying to get it threaded on.

There were a few Picades that went out with one bolt too few. Apologies for that. If you email support@pimoroni.com, then we’d be happy to send you out a little bag with some extras :-)

It seems like you found a solution for the “stuck button”. This was probably due to the button cap not being fitted correctly at the factory. We’ll look into the feasibility of checking each button during packing to avoid this in future.

The keypad issue is a strange one. Could you post a photo of the connection at both ends, please, i.e. the keypad and the display driver board.


#5

Thanks @sandyjmacdonald for getting back to me.

Thanks for the tip, but i took another aproach that worked fine, I just taped the nut on the place where it was supposed to go and then put the screw in, worked great :D

Sure can do:
driver board

keypad

both

Just checked and reseated the cable again, but still nothing.


#6

Ah, yes, I know exactly what the problem is… :-)

You need to put the ribbon cable underneath the black clip to get it into the connector properly. It won’t be making proper contact the way that it is. Also, I guess @tiefschwarz has done the same?


#7

Well now this was a fast solution and I somehow feel really stupid :-P

Thank you very much, never thought of putting it in underneath the clip, lesson learned :-)

Now everything is in working order.


#8

Brilliant! Glad we got the problem fixed. :-)


#9

Correct! I figured I had to do the same as with the TFT display cable.


#10

Just a quick follow up, contacted support concerning the missing screw on tuesday and today I received a complete bag of screws.

Now erything is done with original parts and no more stainless steel screw is “ruining” the fine black exterior ;)

A big thank you to everyone who helped with this.