Only half my lights are active on my UnicornHat


#1

I’m sure I’m doing something wrong, but I’m not a hardware guy. So far I’ve been able to muddle along, but today I’m stumped.

I have a Raspberry Pi3. I have a camera installed and active. I decided to install one of Mausberry Circuit’s cool little rocker switches to turn on/off my Pi. I would like to install the Unicorn Hat by using GPIO PINS. I have included a picture below of my setup. Hopefully you can see what I’ve done. I followed the PIN set up from another post on this forum. I am using 2 (the first PIN on the right side), GND (the fifth PIN on the left side), and GPIO 18 (the 6th PIN on the right side).

Today I ran the following to install the Unicorn Hat software.
curl -sS get.pimoroni.com/unicornhat | bash

I have run sudo apt-get update and upgrade.

Still when I run sudo ./detect.py it says I’m using a Unicorn pHat and if I run sudo ./demo.py I only get 4 of the 8 rows to light up.

Thanks for any assistance!


#2

That is completely normal. The detection scheme probes the system for information registered by the Unicorn eeprom at boot time.

You should either wire up pin27/28 or just enforce the layout in your scripts with set_layout(unicornhat.HAT) as per instruction of detect.py.


#3

Indeed, you are correct. I’m a tad embarrassed. Thanks for your help! I’m shooting sparkling rainbows everywhere.