Unicorn pHAT not working/detecting

OS - DietPi
pi zero w
unicorn phat
pogo pins
5V Power adapter

Added extra ground pin

Installed connected everything else is working but I can’t get the Unicorn pHAT to work. I have set up the pogo pins like stated, heard it could be ground so added a couple more pogo pins for ground.

The device is not being detected and can’t run any of the examples.

sudo python3 detect.py
Unicorn HAT Detect-o-matic v2.0

Note: Your Unicorn HAT must be plugged in before boot to detect properly!

We couldn't find a connected EEPROM, so we'll assume you're using a Unicorn pHAT.

You should use the following in your code:

    import unicornhat

If you're sure you've connected a HAT, use:

    import unicornhat

Not sure what I am missing… I am getting nothing from the examples

Using python3


hello, have you checked here and follow the install

Yes I think so. What I will do is start from scratch… will format the SD card this afternoon.

Will be in touch. Any command I can run to verify a working install?

Your issue is likely due to the OS DietPi. Try PiOS Lite and if it then works go from there if you have to use DietPi. I’d make sure the hardware is fine first then mess with getting the software working on another OS.

Great thanks will do

Thank you @alphanumeric, I wiped the microSD card, installed PiOS Lite and have no more python errors. But I still have an issue with the HAT… it doesn’t seem to work. Not sure its the pogo pins, it seems that there is something with power… I made a video… a small one


Can someone point me in the right direction what I should be doing here? I get only a bit lit up, I put in the pins that were requested and tried different pins as well.


I can try mine with pogo pins and see how it goes , but I not home so it won’t be till tomorrow ,

Thanks. I am not sure what’s up!!

You need pogo pins on all those grounds with the black horseshoe shaped blobs on them in the pinout.
The grounds on the Pi are all wired together but that’s not always the case on pHats and Hats. They all get grounded and linked together “when its plugged into” the Pi’s GPIO header.

Ah okay so add a ground pogo pin to 6,9,14,20,25,30,34,39


referencing image above

Yes add a ground pogo pin to 6, 9, 14, 20, 25, 30, 34 and 39.

Thanks will do tomorrow, and get back to you! Cheers

Okay, I have no luck, maybe I fried it or it doesn’t like me.

I have triple checked my pins and no lights what so ever. Very frustrating…

I have the device running fine, no python errors

I have tried a ton of times, plugged in, can ssh and everything seems up and running. But NO LIGHTS

Try using GPIO 4 for the 5V, just in case the pinout is wrong.

Haha, figured that might be an issue… did that and the same issue… NOTHING 😭

Have you checked for proper connections? If you have a multimeter, try doing a continuity check between each pogo pin and its upper contact ring. Just make sure the Pi’s not powered, else…well, I really don’t know if anything would happen if you left it running, but any consequence would probably be VERY unpleasant.

(I’m assuming each hole is through-plated, else this would obviously not work.)

Thank you @lexfiend but don’t have a multimeter here… we moved about a year ago and still can’t find some tools (ie. lost in action) I took a pair of needle-nose pliers and pushed up each pin to make sure it was connected

best case here? contact support?