Unicorn pHAT not lighting up/responding

I just setup my Pi Zero W with the Unicorn pHAT. When running the examples detect.py properly identifies the Unicorn as a pHAT, however no matter which example I run no LEDs light up or respond at all.

Are you running the examples from terminal or via an IDE?
If your using an IDE like Thonny or Idle, do you get any error messages?

Anything else connected to the GPIO?

Running examples via terminal,

Nothing else connected

Try from an IDE and see if you get any error messages?

Are you running Pi OS Lite, or the with desktop version?

Running Pi OS Lite version

Ok, maybe your missing a dependency. Try running the following and then try an example again.
sudo apt-get install python-pip python-dev
sudo apt-get install python3-pip python3-dev

I have run all these to attempt to get all dependancies

Noticed this on the github page

Using with idle/idle3:

unicornhat needs root access to function. Please make sure you start LXTerminal and run idle or idle3 with the “sudo” command like so:

sudo idle

I would say your going to have to run the examples with sudo

sudo python3 /…

I have been running the scripts using sudo

Ok, I’m out of ideas then? Other than the obvious “make sure its firmly attached to the Pi”.
I have the new Mini and the Hat HD, I don’t have the pHat though so I can’t do any testing of those examples. They won’t work on mine without editing etc.

Thank You, I will try using the desktop and an IDE

Can’t hurt to try the with desktop version. I use that version even on my headless setups. I just go into Raspberry Pi configuration and set it to boot to command line when I’m do all my tinkering and setup.

I don’t know if you want to bother but I’ll throw this out there anyway.
Plasma will work with the Unicorn pHat. Something else to test with.
I’ve run it on my Blinkt.

mine worked using pi4 running in terminal … like this --i changed to the unicorn directory .a few didn’t work ,didn’ try all ,but so far most I tried worked …
pi@raspberrypi:~/Pimoroni/unicornhat/examples $ sudo python ./figlet.py

only issue i seem to have is its upside down ,things are dropping out and snow is falling up,lol have to run a rotate command i guess

Yeah, normal orientation is with the GPIO header across the top, Pi’s Jacks pointing towards you. Pi and Hat laying flat on your desk.
But with displays like this most people will stand it up with the GPIO on the bottom and the Pi’s jacks pointing up. That flips it 180. Your going to want to add
unicornhat.rotation (180)
Options are 0, 90, 180, or 270.

1 Like

Having the same issues with my pHat.

Ran through these steps with no errors still nothing. https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-unicorn-phat

Running detect.py returns that it is a pHat, I’m convinced it might be a board issue. Also using the the Pogo-a-go-go Solderless GPIO Pogo Pins. Installed like this Pogo-a-go-go Solderless GPIO Pogo Pins https://www.youtube.com/watch?v=0Ol3_ME8Ssc&feature=emb_logo

Also tried using a different pi… Hope someone can find an answer.

According to the pinout for the Unicorn pHat, more than just 3 pogo pins are needed.

A lot of the ground pins also need to be connected.

Tried it and even tried soldering one I have an extra still doesn’t work. The pi detects it using sudo python detect.py and outputs the correct response…

I’m out of idea’s? You could try the following.