Unicorn pHAT unresponsive

I have bought a Raspberry Pi Zero W, a Unicorn pHAT, and a set of Pogo-a-go-go Solderless GPIO pogo pins.

Whatever I try, I can’t get the lights on the Unicorn pHAT to turn on.

I was following this guide:

and originally installed DietPi, but am now using Raspberry Pi OS.

From what I understand, you only need to use 3 of the pogo pins, but I have also tried this configuration, to include all 10 pogo pins in the set: https://pinout.xyz/pinout/unicorn_phat

I even tried putting the pogo pins upside down, since I saw a few posts suggesting it might help.

I cloned the Unified Unicorn HAT and pHAT Examples repository, and have tried running the included detect.py script.

It returns “We couldn’t find a connected EEPROM, so we’ll assume you’re using a Unicorn pHAT.”…when I expect it should be able to detect the Unicorn pHAT properly, so I’m not sure if that’s a good indicator of what the problem could be.

Thanks for any help and suggestions…really not sure what else to try!

I’d try putting in another pogo pin for the other 5V pin, pin 4.
And maybe pins 27 and 28, GPIO 0 and GPIO 1, the two eeprom pins.

Thanks alphanumeric. Just tried it, but the same result unfortunately.

I’m not sure how to test whether the pogo pins and/or the Unicorn pHAT are faulty?

A few reviews on The Pi Hut suggest you might have to disable the audio on your Pi first…but these were written 4 years ago…

“…it took me some time to find out that you have to disable internal audio of the Pi first (eg. by executing “sudo modprobe -r snd_bcm2835”. Unfortunately this is not mentioned on the GitHub page or elsewhere…” (https://thepihut.com/products/unicorn-phat)

When I try to execute that command I get the following error:

modprobe: FATAL: Module snd_bcm2835 is in use.

…but who knows if you still need to do that.

Have a look at this thread,
Unicorn Hat not lighting up at all - Support - Pimoroni Buccaneers

And just to confirm, no header on the pHat or Pi?

Good news…I just got it working!

I’ve tested it a few times with a dedicated plug rather than using my laptop’s USB port, and it hasn’t worked…but this time it did…presumably there isn’t enough power coming out of my USB port for both the Pi and pHAT?

A stock USB 2 port is limited to 500ma.
EDIT:
Also be careful of using “chargers” instead of power supplies. Phone chargers etc don’t always regulate the voltage correctly for Pi. I recommend the official power supply for problem free power.

Bad news…it doesn’t really appear to work.

After I got it working yesterday, I removed some of the pogo pins I thought I wouldn’t need, and then it stopped working completely, even after I put them all back in.

I’m not sure if some of the pogo pins are broken, or just unreliable, but it took a few attempts of rearranging them before it suddenly started working again.

And then I just started seeing more unusual behaviour.

When I sent a command to turn on one of the LEDs, half the grid would light up.

Right now I’ve got the API from the article above installed on the Pi, but it ignores anything it receives, and the LEDs don’t change. They should only show all red/yellow/green when it’s working properly.

All it’s showing is this:

I didn’t set those LEDs/colours, so what’s most likely causing this erratic behaviour?

My gut feeling is its the pogo pins causing the issue. That’s my best guess as I really don’t know why your having the issues your having.
I have the Unicorn Hat HD, and HD Mini, both come with the headers already soldered on. Even so I would have soldered on a header.
I highly recommend learning to solder if you don’t know how already, and installing soldered on headers.

My gut feeling is its the pogo pins causing the issue

I’d agree, the behaviour you’re seeing is common if there’s a poor connection between Neopixels and their data source. Pimoroni show it working with the Unicorn pHAT, but it seems like the potential obvious culprit.