Unicorn pHat DOA?


#1

I just purchased a unicorn pHat for my son’s GCSE engineering project to go with his brand new Pi Zero W for the project (we bought the Pimoroni Raspberry Pi Zero W Project Kit)

I wanted to do some tests to make sure its working as expected before he starts coding, but alas none of the examples do what I would expect.
The Pi is fitted into the pimoroni case that it came with (starter kit) and the pHat is connected per the diagram (https://pinout.xyz/pinout/unicorn_phat) using the Pogo pins until everything works as we expect.

The example scripts seem to work out that its a pHat rather than a Hat by detection and leaving AUTO as the default setting in the script.

We’ve installed the unicorn libs using " curl -sS https://get.pimoroni.com/unicornhat | bash" and still no good. We’ve completely re-installed the OS (stretchy) and updated everything and then done a fresh unicornhat install but still no go. It seems to stop after the first line of LEDs and then a broken signal gets through? since the other LEDs (downstream) seems to go haywaire a bit.

I’m pretty sure “bluesky_greengrass.py” is supposed to light more LEDs and not have any red in it?
unicornphat|666x500

Thanks
Si


#2

Did you pogo pin all the grounds listed in the pinout?
Pins 6,9,14,20,25,30,34 and 39.