OnOff Shim keeps causing reboot

#1

My OnOff shim is working strangely. It powers the PI 3 just fine and when I hold the button for a second it starts a shutdown as expected but after the shutdown the Pi reboots straight away.
I tried a shutdown from the command line and from the GUI menu and in both cases the Pi shutdown and then immediately restarted again.
I reinstalled the software with the curl command a few times but nothing changed. If I take take the OnOff shim off and power the Pi as normal it does shut down so it suggests something about the shim itself is the issue.

I soldered it to the supplied female header so I can take it on and off. The solder looks ok, it all seems to be making contact with the copper and I did re-do the pins but that didn’t fix it.

It does shutdown so the button is registering and the software does cause the shutdown to happen but it seems something is going wrong, maybe with Pin 4, causing the restart. 1-wire is disabled.

How do I troubleshoot this further? Is there something in a config file to check or some way to monitor Pin 4 or check that it is being pulled low at the end. Is it worth powering the shim away from the Pi and checking voltages and what would I check? Can I change the config to use a pin other than pin 4 or 17 to see if other pins work? I have a voltmeter and can supply 5v to the shim away from a Pi if needed.

Any ideas?

0 Likes

#2

Have to ask the obvious question. ;)
Power supply is connected to the shim and not the Pi?

0 Likes

#3

Yep, power to the shim not the Pi directly, but worth asking :)

0 Likes

#4

Hello everybody,
I have exactly the same problem. Do you have any solution?
THX

0 Likes

#5

Ok, next question is what are you both using for power supplies? Specifically what is the current ratting?

0 Likes

#6

I tried different supplies.

  • 2 A
  • 2,3 A
  • Anker power core 4,8 A

If I shut down the system over rasberian ui it reboots as well.
If I run the pi without onoffshim everything is fine.
It seems like the shim gives the reboot signal instantly after shutdown.

EDIT: I checked the behavior of PIN4 with my multimeter. After shutting down the PI the voltage drops for less than a second to zero and comes back to 3 V.

0 Likes

#7

Always done this or only just recently started doing it?
Make sure there isn’t a short between physical pin 5 (GPIO 3) and physical pin 7 (GPIO 4).
Grounding GPIO 3 pin 5 on a model 3 Pi will make it boot up.

0 Likes

#8

I checked this and there is no short between this two pins.

I think the shim can not cut the power correctly. Is there any other possibility to check this?

0 Likes

#9

I’m using an official Pi power supply. Same as Coulomb I see Pin 4 go low and then back up to 3.3v and I can’t see a short - but I have soldered the supplied female header to the shim.
I did try changing the pin from 4 to one of the other pins. That let the shim shut down the Pi correctly when the button is pressed but then it wouldn’t let it start back up again.

Happy to try any other experiment/test you can think of.

0 Likes

#10

Ok, was grasping at straws a bit looking for the pins being shorted, to be honest.

Back to my other question, has it always done this or just started doing it after say an apt-get update / upgrade?

0 Likes

#11

In my case it has always done this. I installed it yesterday and its always the same.

0 Likes

#12

Ok, was wondering if the Pi foundation updated / changed something that may be messing things up?
I don’t own one so there isn’t much more I can do to help.
If you go to the Shop page there is a Contact Us link at the bottom of the page. Clicking that will let you e-mail Pimoroni tech support directly. Just put a link to this thread in the e-mail.

0 Likes

#13

For everyone else with this issue:

I wrote with the service team and got the tip to renew the solder points.
After resoldering the shim works fine.

Thank you for your support.

0 Likes

#14

Nice to hear you got it working. =)

0 Likes