Pan tilt hat, detected, but doesn't move

I just got the pan tilt hat and did all the setup, installing pantilthat, pimoroni, etc. I ran “sudo i2cdetect -y 1” and got the following:

 0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f

00: 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f
10: 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f
20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f
30: 30 31 32 33 34 35 36 37 38 39 3a 3b 3c 3d 3e 3f
40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c 4d 4e 4f
50: 50 51 52 53 54 55 56 57 58 59 5a 5b 5c 5d 5e 5f
60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f
70: 70 71 72 73 74 75 76 77

I’m trying to run the pan tilt web example from github, and while everything runs and the console displays get requests whenever a push a button on the web gui, the pan tilt hat never moves. It’s as far onto the gpio pin as i can push, and i’m not sure what the problem is.

Any help is appreciated, thanks!

I have a PTH and I noticed it makes a small movement of the servos when I power up the Pi. Does this happen?

What do you get with i2cdetect without the PTH connected?

I found this on a search but it may not be the same as your issue:

What @Crowbot said. Every address displayed by i2cdetect means you have an i2c issue. Likely a short to ground on SDA or SCL. Or those pins are shorted together.

My first Pan Tilt does the slight servo moment on power up / boot up.
My second one I bought just recently doesn’t though?
I haven’t compared the two boards for different revisions etc. I only noticed it after I had it all assembled and setup in Motion Eye. Both are running Motion Eye.

My servos do move slightly on powerup. What could be the source of the short? I’ve double checked that the servo connectors on the hat are seated correctly. Currently I’m not using standoffs on my pi 3b to space the hat and she pi, but they dont touch so I’m not quite sure what could be causing it.

Normally I would say double check your soldering of the GPIO header but the Pan Tilt Hat comes with it presoldered on? And if its any model other than a Pi Zero its header is already soldered on.
Remove the Pan Tilt Hat and run i2cdetect again. If it comes back all 0’s the Pi should be fine. If you get the same thing all addresses shown your Pi has a hardware fault.
If its all zeros, put the Hat back on and run it again. If it comes back with all addresses detected its a fault on the Hat.

I followed your troubleshooting steps, and i ran i2c detect with the hat off. All addresses were detected like with the hat connected, so it is indeed something with my raspberry pi.

I looked at the stackexchange post, as well as others, and nothing around my SDA Pin 3 seems off.
Could this be a software issue? i ran into this after installing various dependancies for openCV, and my raspberry pi worked previously for a project before.

One way to find out is to do up a stock install of Raspbian on a spare SD Card. Don’t install anything third party or edit anything. Then turn on i2c, reboot and run i2cdetct.
If you still get all addresses detected the Pi almost certainly has a hardware fault.
If it’s all Zero’s like it should be, it was something you did software wise.
You could even just swap an SD card from another working Pi in temporarily. If the problem Pi boots from it then turn on i2c, reboot and run i2cdetct.

I’ll do a stock install of raspbian. If that doesn’t work, i’ll get a new pi. Thanks for your help!

I’m pretty sure its a hardware issue on the Pi. Not 100% sure, but its what I think your problem is. Good luck, if I’m wrong all you have to do is start over with a clean install. Then keep checking it as you change things to see what breaks it.

Just a quick followup, i did a clean install and it was indeed a software issue. No addresses are displayed, just dashes!

Thats great news, hardware is all fine then. =)