Phatdac Pi zero slooooow audio


#1

I got the Pi Zero - love it , added a phatdac, it makes sound. I ran the installer from the phatdac install, and I DO GET SOUND, but it is slooooow, like playing through mud. Even when I run the install script the second time, and it asks “Do you want to test?” and I say “y” it plays the ‘Left Front’ ‘Rear’ ’ Right Front’ sounds and I HEAR the sound through my speakers, but the sound is like a dude with a super low bass voice is talking reeeaalll sllloooowwww. I use aplay or mpg123, or even mpd, and it is the same. I have a “The Offspring” mp3 file, and it makes sound, but again, it is sloooooowwww, not CPU slow, but audio slow, like playing a 45 record at 33 rpm speed ???

What’s up with this ?

p.s. I tried two pi, put the phatdac on either one, same thing.
I have Jessie, dist-upgraded to latest 4.4.14+ release,

Anyone else experiencing this ? I have not seen this on forum, It seems very weird for me to have done some mistake, to make it work… but to make it work so weirdly ??

Please.


#2

It sounds like there is a sampling rate mismatch.

In theory it should make no real difference if you started with a recent image, but you might want to try and see if you get a different result by not applying apt-get dist-upgrade or even apt-get upgrade.


#3

Did you dist-upgrade or rpi-update to the 4.1.14+ release? As far as I’m aware the latest kernel is 4.1.13+ which I installed last week to compile some kernel modules, so anything beyond that will be untested and unfinished.


#4

I appreciate the answers, “uname -a” was returning 4.4.14, so I had done the dist-upgrade and probably the rpi-update also (thought it was best to always have the latest update ???).
I really do appreciate the answers Thank You.

I wiped my memory card and started fresh from scratch, (now only at 4.4.11+ ) and I was able to get it to work. The only thing I can think is that previously, I had edited a few things in my boot-config.txt to get hdmi output working (and maybe I had tweaked some things to get audio out the hdmi connector also), or maybe it was the dist-upgrade that hosed it up, (as Rogue M and gadgetoid alluded to). On the fresh OS install, and re-install of the phatdac software, as I said, It is Working, straight away no problems, easy peasy -> Happy.

Now I will go back and try slowly to tweak back to getting HDMI output working again, hopefully not messing up the audio. (I have vnc, and ssh, so I am not totally blind working with the Pi…)

Phatdac and mpd, and mopidy is a nice deal… man, I just wish I could get me some volume control…

really, Thank You for answering. Nice to know I am not alone out here.


#5

Interesting… I checked one of my other pi Zero, and uname -a says:
"4.4.14+ #895 Sun Jun 26 13:39:34 BST 2016 armv6l GNU/Linux"
checking my ‘history’ and I do show an rpi-update command

Should I not be doing a rpi-update ?? does that give you ‘untested and unfinished’ ??

I figured dist-upgrade and rpi-update were ‘okay’ to do once in a while ??
Should I just stay at some OS level forever ??

Thanks, for your response, I do appreciate you Pirates.
Love getting little pirate booty packages in the mail.


#6

rpi-update is indeed not recommended, it will pull down things that are highly experiemental.

dist-upgrade and upgrade are somewhat similar and it’s a good idea to run them once in a while, they are unlikely to break anything, though if you have a Pi with a specific function and it works as intended staying put is not a bad choice either.