No sound from PhatDAC after Raspbian Pixel upgrade


#1

Raspberry: RPi 2
OS’s: Raspbian Pixel (Jesie) & LibreElec in the same SD card.
Hardware: Pimoroni PhatDAC

Hello, I had a nicely running media server using older Raspbian Jesie and Kodi installed within Raspbian. The sound coming out of PhatDAC was awesome and then, I upgraded software and now there’s no sound.

I did the automated PhatDAC installation offered by Pimoroni and I can do the test “right, left, right, left” and hear it. However, it won’t produce any sound after that.
I have installed and reinstalled Raspbian about 9 times and tried this and that but nothing has worked.

Help! I miss my music.

Thank you!


#2

whether or not you can direct sound to the DAC depends on whether the application you are using are going through ALSA. I’m slightly confused by your stated environment though, isn’t LibreElec a full OS distribution?


#4

Hi Rogue, it is the whole operating system. I had Kodi before but within Raspbian and I wanted some features that after trying upgrading Kodi inside of Raspbian, I noticed it’s only available if I have Kodi as a stand alone. Features such as creating my own playlists.

I mention Raspbian because I am trying to configure PhatDAC from within raspbian. Yesterday I was able to do the “right, left, right, left” test (still inside Raspbian) and then rebooted into LibreElec and at least I saw the option to choose what I believe is the PhatDAC from the audio menu, but there was no sound however so I went back to the drawing board.


#5

right… but if I’m following you are multi-booting the OSes? things you do in one - such as setting up the hardware - don’t carry to the other, they both will have their own boot (and root) partition, with distinct configurations.

I will have to try LibreElec in the next few days and see what the difficulty might be, but I do remember some peculiarities with OpenElec, which I suspect apply to this sibling OS.


#7

Let’s forget LibreElec, I will be very grateful if you help me getting the PhatDAC to work inside Raspbian Pixel.

Do you know a guide? Basically, the one I followed before does not work for neither LibreElec nor the new Raspbian Jessie with Pixel.

I tried already this: curl -sS get.pimoroni.com/phatdac | bash

and the manual procedure also mentioned in the page where I got the above from. It gets as far as doing the test “left, right” which I can hear clearly while connected to the PhatDAC. But after a reboot:
-The speaker icon gets crossed out.
-if I go to raspi-config it doesn’t let me do anything, I forgot what it says.

Thank you


#8

it is completely normal that the icon is crossed out in the desktop lxpanel - it controls the on-board chip, which is disabled by the script.

If speaker-test works then your hardware is set up properly, and if the application you are using to play music supports ALSA then it should work. Not all applications do.


#9

Thank you for your reply.

In Raspnian. after the test and reboot, what I have tried is load a youtube video in chromium. There’s no sound.

What I did notice is that if before installing the PhatDAC I listen through the Pi’s integraded AUX jack, the sound is okay (as long as I don’t raise to volume, reason I bought the PhatDAC). But then I install the PhatDAC, the “left, right” test is clear through the PhatDAC’s input jack but after reboot, there’s no sound anymore out of the PhatDAC.

BUT, if I switch the plug back to the integrated AUX, sound comes out, but dirty, kind of mixed with white noise. And yet the PhatDAC itself is not producing sound any longer after the test.