PhatDac Install issues


#1

Hi, I have a Phat-Dac and I cannot seem to get any sound out of it.

I followed these directions:

http://forums.pimoroni.com/t/phat-dac-install/1306

I did actually have it working at one point but now I cannot get it to work, I have tried the latest Raspian and Noobs but still nothing.

My question is, what is the best way to debug this, is there some kind of control panel that will list installed devices?

Any command line diagnostics?

I have tried using it with a PiZero and a PiZeroW.

Thanks,

Phil


#2

Hi Phil. I’d recommend that you try installing with our one-line-installer. Just open a terminal and type curl https://get.pimoroni.com/phatdac | bash. That should set everything up as it should be. How are you testing it, out of interest?


#3

Hi, I did use curl https://get.pimoroni.com/phatdac | bash to install it.

as part of that install, it does a test at the end.

I would love to know any other tests you have that can see if it PhatDac is installed.

Cheers.

Phil


#4

Is it soldered, or using a hammer header?


#5

I used a Hammer Header.

Could this be the issue?


#6

Hammer headers are usually just as, if not more, reliable than soldered headers. Though just double check that your Phat is well seated.

Could you try running “alsamixer” in your console and checking if your hat is listed? This should give you a console with your connected cards.


#7

This is what I see when I run alsamixer vis ssh.

I’m guessing this means the card is detected.

Phil


pHAT DAC no sound issues
#8

That looks like the software is set up correctly- although the Pi will be completely unaware if there is a DAC attached or not, it’ll output the signal regardless.

What are you using to attempt to play audio?


#9

I was using MusicBox.

I tried a different PiZero, reconnected everything and it all seems to be working now.

Thanks

Phil