Phat DAC install


#1

I’ve been following this guide
http://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install
using the latest Jessie on a Pi Zero.

The files mentioned don’t have the lines suggested.
/etc/modprobe.d/raspi-blacklist.conf
is empty and
/etc/modules
only has i2c-dev listed

I went ahead and added asound.conf and added the line to /boot/config.txt, checked i2c was enabled and rebooted but I don’t seem to have any sound working. I tried:
aplay -l
and only see bcm2835 related things listed.

Can anyone suggest something to try?

thanks!

J


PhatDac Install issues
#2

I had a typo in config.txt! It works great :)
(Though the instructions could do with a tweak as that helped me doubt what I was doing!)


#3

I’m up for tweaking the instructions if they’re unclear. I was sure I was running from the latest Jessie also, and those config files did have the modules mentioned. Which is odd!


#4

I’ll reset my card and try again :)


#5

Hi!

Could you tell me which GPIO pins the pHAT DAC uses? I would like to combine it with the Adafruit 2.2 inch display HAT.
Also, do you need a separate headphone amp when you use the pHAT DAC?

Thanks in advance!


#6

cant help with pins but can tell you its line out, so you will need an amp


#7

Thanks for the quick reply!

I will use a separate headphone amp to make it into a portable mp3 player.


#8

I’ve got a little pair of active speakers in mine, some Nokia one with a volume control. It sounds great!

I did a video but it was a bit pointless :)


#9

I have a rather stupid question with regards the pHAT DAC. How do I attach it to my Pi Zero? Mine arrived this morning but I can’t figure out how to get the boards to connect to each other. Is soldering required? If so, are there instructions on how to go about doing this?

Thanks


#10

Hi Nick, did you get one of these in the packet?

You solder that on so the black part is under the DAC and then it’ll push right on to the pins on the pi. If you didn’t get one I’d suggest using the contact us for on the shop site ( https://shop.pimoroni.com/pages/contact-us ) to contact Pimoroni and I would expect they’ll sort you out.


#11

The way I personally do it is to use some blu-tack (or white tack in this case) on the other side of the board from where I’m soldering to hold the header exactly where I want it. I then do one pin at each end of the header and check that its still seated against the board and at right angles to it. Then if everything looks good I take the tack off and finish the soldering. Once its all soldered up I give it a close look, with a magnifier if I can find it, to make sure there aren’t any little bits of solder bridging any the pins. I also like to let the board cool down briefly after doing a small number of pins as if you do the whole thing in one go it can be rather warm by the end.

End result:

The white tack. I don’t know how it reacts to the heat so I only leave it on while I do the first 2 pins, after which things should be fixed anyway:


#12

Wireless player!


#13

That’s a really nice setup, and some useful instructions! Good show, sir, good show!


#14

Is there a way to identify the pHAT DAC over i2c like you can with most of the Hifiberry products? I see you use the same device tree overlay as the Hifiberry DAC which doesn’t have this feature, does this mean the pHAT DAC also doesn’t?


#15

I too found that raspi-blacklist.conf file was empty, and etc/modules only had i2C-dev listed - this was on a fresh Jessie install (I think the new overlay method of configuration does not need blacklist.conf).
I found that just creating the asound.conf file and adding the dtoverlay=hifiberry-dac to the /boot/config.txt file was enough to allow the DAC to be used, although the only way I found of selecting it was through VLC player (it wasn’t selectable from the desktop volume control). Hope this helps (a bit!)


#16

Thanks! It helps me to know I’m not going crazy ;o)

I have a feeling that disabling the hdmi audo device will cause the Phat Dac to become the default which would be handy, but I’m not sure how to do that. I’ve always tried to avoid playing with sound on Linux!


#17

Oh I recently set up pHAT DAC in Lakka OS to get sound out of the Pi Zero for sweet, sweet retro gaming goodness, it worked, I just needed the overlay and one blacklist entry adding.

It looks like my instructions target a slightly earlier OS version and need updating.

As far as I can tell, no removal of anything from the backlist is needed, but to make the pHAT DAC the default audio out you’ll have to add a blacklist entry for the bcm2835 sound module ( as mentioned in the guide ).

I’m still trying to figure out if there’s a configuration method that will leave both cards enabled but make the DAC the default. Right now I think they are listed in the order that they load, and the BCM audio is always first.


#18

Yes, instructions are a bit confusing as most of it is unnecessary on Jessie (full or lite). there should soon be a one-line-installer available that should make things simpler and support both old and new.

Re pins used by the pHAT DAC, @gadgetoid has to confirm but I suspect it would be BCM 18,19,20,21 for i2s, combining it with other add-ons shouldn’t be too difficult.


#19

Thanks for the indication of the used pins! These are nearly the same as the HifiBerry DAC+. Makes sense, since they use nearly the same hardware.


#20

There is now a one-line installer that will take care of setting up the pHAT DAC on your Pi:

curl -sS get.pimoroni.com/phatdac | bash

It will instruct you to reboot if needed (which would be expected on a first run), and offer to run a quick test if all seems good to go.

Let me know if you run into problem but it’s been extensively tested (neighbours can attest!) on both Wheezy and Jessie. If your system is too old (no device tree support) it should also tell you…