Could someone provide a working Image to test PHAT DAC


#1

Hi
I’m trying to convince my PHAT DAC to give out any sound, but til now with no success :-(

I’ve tried to go by this tutorial :
https://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install (with no sucess neither within the different Music players i’ve tested, nore with the built in test routine from the config tool)
and read through many forums and tested everything I could think of, but still no sound.

I’ve got two Phat DACs soldered, one with all pins soldered and one lazy soldered (just the needed PINS)
I’ve tried both on a brand new PI ZERO W as well as on a Raspberry PI 3 Model B V1.2
the Amplifier and Headphones i’ve connected both work well with other line sources.

Does anyone has an idea what I could try out, or could someone provide me with a working Image of any kind with working sound?
So I could test if something with the DACs is wrong.
I have a MICRO USB Keyboard and Monitor as well as an other Machine at hand to connect via SSH.

Thanks in advance


#2

have you made sure that I2C is enabled?


#3

I added the line:

dtoverlay=i2s-mmap

into the /boot/config.txt

Is this what you meant?


#4

Step 1: All The Modules

In Terminal, type: sudo nano /etc/modprobe.d/raspi-blacklist.conf to open the module blacklist file. This file prevents certain modules from loading at startup. With the file open, comment out the lines corresponding to the modules we want to load by changing:

blacklist i2c-bcm2708
blacklist snd-soc-pcm512x
blacklist snd-soc-wm8804

To:

#blacklist i2c-bcm2708
#blacklist snd-soc-pcm512x
#blacklist snd-soc-wm8804

#5

I did this too, like it was written in the setup guide (I tried automatic and manual setup)


#6

all of the above is superfluous and not necessary for Raspbian Jessie. Using the manual instructions could work, or not, at this stage.

The only thing you really need is the hifiberry dtoverlay in the /boot/config.txt file, but not the one you mention (you can load that one too for more complex setups, don’t be surprised in the volumealsa lxpanel plugin in Raspbian pixel breaks your setup, it is not very accomodating).

Anyhow, to summarise the situation, start from a clean image and run the automatic setup. If you need a custom audio configuration beyond that (to provide software volume control for example) then do it in a second stage, testing every change separately so you know what to undo when things go north…


#7

Did you ever manage to get this working? I have the same issue.

Raspberry Pi Zero W (brand new)
Phat DAV (brand new)

To ensure a clean start I just downloaded and re-installed Rasperian. Other than setting up SSH to connect to the Pi, I’ve done nothing to it.

I then ran the automatic setup for phat DAC:

curl https://get.pimoroni.com/phatdac | bash

I have some speakers that I know work fine (I used them yesterday with my laptop) plugged into the line out. I run “speaker-test” from command line and I see it testing, but there is no sound.

Before re-installing the OS to ensure a clean slate I had also tried manual install, auto install and pimeroni dashboard install. None of those worked.

I am using a T-Cobbler and breadboard. Connections with the Phat DAC are with hammer heads. Please see pics.

I’ve wired it as per the pinout diagram here https://pinout.xyz/pinout/phat_dac.

Purple wires are the ones for the Phat DAC.

Any ideas welcome please!

Thanks

Dougi

pi1pi2


#8

I could be wrong, but it doesn’t look like you’ve connected any of the grounds up on the pHAT DAC? You’ll find the pinout for pHAT DAC below.