Picade issues with certain crt shaders


#1

Hello everyone,
I am so happy to have found out about the Picade and the Pimoroni pirates. I am enjoying so much the fiddling and setting up the cabinet but there are some issues I keep encountering and I was wondering if someone has any idea why it happens and how to fix them.

So far I have encountered the issue with the turbografx and snes emulators. I updated the internal online list for shaders in retroarch and so far been very happy with the crt-pi shader that is being discussed here:

The that thing happens(I’ll try to describe it as completely as possible…) is that when you run some intensive games( like Aladdin for SNES, Final Fight for SNES, Castlevania X for turbografx,…) and have loaded the preset for the crt-pi shader the LCD screen blacks out with the sound, which for a second later intensifies and normalises. The LCD screen then after 2 seconds approx. comes to life. The emulation on the PI is uninterrupted when this happens. This can be triggered when moving your stick + pushing a button(which makes me think the problem is inside the PICADE PCB) or sometimes by just leaving the emulation go on and not touching anything.

If I change the shader to some non crt(without scalines) everything functions perfectly. The shaders where this can be replicated are also some which have the name “phosphorous” or something in the name.

1.)I thought the issue is related to power. I have the official 2amp 5V adapter for my PI 2 modelB 1GB. I tried connecting the PICADE PCB to a separate power supply and strangely the stick + buttons did not work? huh? The supply was 5V 1Amp

2.)I tried than using the same supply on the LCD(stock 8") separately and got no sound whatsoever?

I am not sure what is the problem but it is possible to repeat the issue and it is related to graphically intensive roms when using certain shaders with retroarch. I thought maybe someone encountered these and could help me a little. I am also quite sure this is related to the Picade PCB since the blackouts cut off the display and the sound when pushing buttons and the stick at the same time.

Thanks Pimoroni for the Picade I am very happy with the quality of the kit.

best regards,
Greg


#2

Just a quick update… I managed to solve the issue with the suggestions from here:

http://forums.pimoroni.com/t/my-screen-keeps-cutting-ot/1515

:) so far so good, I’ll try some more tomorrow