Picade Plasma unresponsive lights


I recently acquired a Picade and decided to include the Plasma buttons and while this is my first time assembling something of this nature, in the end I managed to get the Picade working… except for the Plasma buttons.

For some reason, whenever I turn on the Picade all of the buttons flash for an instant, as seen in this video, which leads me to think that they are connected “correctly” to some extent (no defective wires, hopefully). After booting, only some buttons stay lit (and always the same) and not with all of their LEDs, as shown in the image. Colors also seem to change at times from boot to boot.

I installed the Picade Plasma software as indicated in the dedicated instructions page, with the hope that that would fix the issue. I even tried using the plasmactl command with different color values like in the examples, and while the command was recognized, the buttons never changed color.

So I’m clueless now. I’m unsure if I got the wires incorrectly or something. I’d hate to replace these with the regular buttons. Not sure if anyone has faced this situation before.

Any help or comments are greatly appreciated :D

Hi !
Same issue here. I make it works a first time, but since I needed to unmount my Picade, now it’s not working anymore… Same result with the command or with a program in Python.

Hi guys, I am having the same issue as the guy above. I have run the recommended install and all I get is about 3 leds come on. If I try to run plasmactl nothing happens either. Can anybody help? Thanks

The instructions were wrong for me. I needed to swap the data and clk lines going to the BTN7 and BTN8.

Hope this helps

Latest commit has swapped these: